Feedback Imprimir

Dicionário de Dados

O dicionário de dados é uma ferramenta importante para a internacionalização dos sistemas, utilizando este recurso é possível criar um repositório de dados, podendo ser associado a uma ou mais tabelas.

Para acessar esta funcionalidade devemos acessar o menu principal Ferramentas > Dicionário de Dados.

Criando um Dicionário de Dados

Informe as informações necessárias para a criação do repositório. Os campos com asterisco são obrigatórios.

Tela inicial do dicionário de dados

A opção Associar Repositório define se a conexão será associada ao repositório de dados, permitindo que as novas aplicações, criadas utilizando as tabelas adicionadas ao repositório, possuam índices nos arquivos de idioma com os labels dos campos da tabela.

Adicionar Tabelas no Repositório de dados

Aqui devemos selecionar as tabelas que serão adicionadas a este repositório. Após selecionar as tabelas desejadas clique em prosseguir.

sincronização de tabelas

Após selecionarmos as tabelas desejadas, devemos definir a criação ou não dos índices (langs) na label dos campos nas aplicações existentes no projeto.

Gerar índices nos arquivos

  • Gerar índices nos arquivos de idioma com os labels dos campos da tabela - Nesta opção as labels dos campos serão substituídas por índices que poderão ser editados em um único local ao acessar Localidades > Idiomas das aplicações.

Exemplo de um índice criado pelo dicionário de dados: Label dos campos com índice

  • Sobrescrever índices existentes nos arquivos de idiomas - Nesta opção os índices existentes serão substituídos por novos com os dados atualizados a partir da base de dados.

Em seguida podemos visualizar a lista das tabelas adicionadas ao repositório de dados, onde iremos visualizar algumas informações sobre estas tabelas como o nome da tabela na base de dados e o índice criado para cada tabela, no campo label, e a versão do dicionário de dados de cada tabela.

Tabelas sincronizadas

As tabelas que não foram adicionadas podem ser visualizadas ao acessar Tabelas da base de dados, o processo de inclusão destas tabelas ao repositório de dados é o mesmo.

Ao realizar alguma alteração na estrutura das tabelas na base de dados, a mesma deve ser atualizada utilizando a opção Sincronizar dicionário.

Status das tabelas

Junto ao nome das tabelas existe um ícone que indica o status das tabelas.

  • Verde - Indica que a tabela e o repositório estão atualizados.
  • Vermelho - Indica que a tabela não existe na base de dados, neste caso devemos selecioná-la e remover do repositório.
  • Amarelo - Indica que a tabela está desatualizada por alguma alteração na sua estrutura. Nestes casos devemos clicar no link editar referente a esta tabela e clicar em atualizar para que os dados do repositório sejam atualizados.

Editar Tabelas

Pode ser encontrada no lado direito, na lista de tabelas.

Editar tabelas do repositório de dados

Esta opção nos permite editar os campos da tabela escolhida, como tipo de dados e os índices criados pelo repositório de dados por exemplo.

Opções de edição das tabelas

Outras propriedades dos campos podem ser acessadas ao clicar no ícone mais no canto direito da lista de campos.

Mais propriedades

Sincronizando Dicionário

Esta opção é ativada ao selecionar uma ou mais tabelas, nesta opção iremos atualizar os dados do dicionário de dados de acordo com a base de dados.

Gerar índices nos arquivos

Ao sincronizar as tabelas, um ícone amarelo será exibido ao lado do nome da tabelas atualizada, veja como remove-lo. Em caso de alteração na estrutura das tabelas devemos sincronizá-las novamente.

Sincronizando Aplicações

Após realizarmos todas as configurações desejadas nas tabelas e campos, devemos sincronizar as aplicações existentes, para que recebam as alterações realizadas.

Primeiramente devemos selecionar as tabelas que devem ser sincronizadas.

Tabelas que serão sincronizadas

Em seguida, podemos definir o que será alterado e quais aplicações irão receber as alterações. A listadas das aplicações, que receberão a alteração, são baseadas na tabela utilizada por elas.

Aplicações que serão atualizadas

Ao clicar em sincronizar, ao finalizar o processo teremos um resumo do processo realizado.

log

Ao clicar em mostrar log, poderemos visualizar todas as alterações realizadas, onde será exibido como estava (cor azul) e o resultado da alteração (cor vermelha)

Log de alterações

Ao clicar em Voltar retornamos para a tela de definição das alterações.

Para finalizar o processo devemos clicar em Fechar.

Editando Propriedades do dicionário de dados

Na parte superior poderemos visualizar as propriedades do dicionário, informadas no momento da criação.

![Propriedades do dicionário de dados][dicionario-013]

Temos três ações possíveis, editar, recarregar e fechar.

  • Editar - Permite a alteração nas propriedades do dicionário de dados, como a alteração da conexão utilizada e a definição da associação do repositório com a conexão por exemplo.

Tela de edição das propriedades do dicionário de dados

  • Recarregar - Atualiza todas as informações do dicionário de dados, como o status das tabelas por exemplo.
  • Fechar - Fecha o dicionário de dados atual e somos redirecionados para a lista de dicionários.

Editando os Índices

Para editar os índices criados no repositório de dados, acesse Localidades > Traduzir Aplicações.

No painel lateral é possível visualizar todas as langs do Scriptcase. As langs referentes ao dicionário de dados estarão dentro da pasta Mensagens do projeto.

edição dos índices