Autor Tópico: Erro gerando código fonte.  (Lida 919 vezes)

alfonso2013

  • Novato
  • *
  • Mensagens: 33
Erro gerando código fonte.
« Online: Novembro 10, 2014, 02:52:06 pm »
Olá Pessoal.
Tínhamos um sistema funcionando lindamente com um banco de dados MSSQL Server Express, foi atingida a capacidade máxima e mudamos para PostgreSQL e nalgumas aplicações do nosso sistema na hora de recompilar o código fonte me esta a emitir o seguinte erro:

"Undefined offset: 45 | Script: C:\Program Files\NetMake\v8\wwwroot\scriptcase\prod\third\adodb\drivers\adodb-postgres64.inc.php linha: 572 "

Há alguma sugestão???     Já não sei que fazer.
Cptos.
   Alfonso

Jailton

  • Expert
  • *****
  • Mensagens: 2034
Re:Erro gerando código fonte.
« Responder #1 Online: Novembro 10, 2014, 03:08:01 pm »
Muda para o MySQL que ele vai rodar Lindamente novamente.
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.

alfonso2013

  • Novato
  • *
  • Mensagens: 33
Re:Erro gerando código fonte.
« Responder #2 Online: Novembro 10, 2014, 03:26:14 pm »
O problema é que a aplicação Web é um complemento duma aplicação desktop que agora já esta a funcionar sem problema em postgresql, alem disso já foi feita a transferência de todos os dados de MSSQL para o novo banco de dados Pg que são como 15 GB.
De qualquer forma obrigado pela dica, gostaria de ter mais ideia para avaliar que fazer no final....



Jailton

  • Expert
  • *****
  • Mensagens: 2034
Re:Erro gerando código fonte.
« Responder #3 Online: Novembro 10, 2014, 04:35:08 pm »
Já tentou fazer isso:
http://www.scriptcase.com.br/docs/pt_br/conectando-sua-base-de-dados/postgresql/habilitando-o-postgresql-no-windows

E tenta usar com conexão: PostgreSQL PDO (você deve remover o ponto e vírgula da extensão php_pdo_pgsql.dll).
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.

alfonso2013

  • Novato
  • *
  • Mensagens: 33
Re:Erro gerando código fonte.
« Responder #4 Online: Novembro 10, 2014, 05:31:53 pm »
Olá Jailton, obrigado mais uma vez.
Eu uso WampServer, não entanto confirmei como sugeres se as extensões de PHP para PostgreSQl estão activas, mudei para PDO e voltei a recompilar e ao final, igual. Agora me diz que o problema é em

..\wwwroot\scriptcase\prod\third\adodb\drivers\adodb-pdo_pgsql.inc.php

na linha "X", este é um arquivo de Scriptcase, se não é um bug, se parece muito ou pelo menos deveria indicar melhor qual é o erro.