Autor Tópico: Problema com Imagem na macro sc_appmenu_add_item  (Lida 1294 vezes)

renatovdemoura

  • Iniciante
  • **
  • Mensagens: 72
    • Email
Problema com Imagem na macro sc_appmenu_add_item
« Online: Setembro 23, 2014, 04:02:17 pm »
I ae galera blz??

To com um problema na macro sc_appmenu_add_item.

no onload:

sc_appmenu_reset(menu_teste);
sc_appmenu_create(menu_teste);

sc_appmenu_add_item('menu_teste', 1,'',1,'blank',tipo='G',"../_lib/img/imagem.png",,_parent);

Ele cria o item do menu na moral. O problema é que a imagem não carrega de forma alguma.
a imagem existe, e adicionei tb a imagem em Aplicação->Configuração->Ícones Extras da Aplicação

alguem tem idéia ai?
Haroldo? hehehe

alvaromoura

  • Novato
  • *
  • Mensagens: 29
Re:Problema com Imagem na macro sc_appmenu_add_item
« Responder #1 Online: Setembro 23, 2014, 06:09:28 pm »
Boa tarde.

Ao realizar o upload de qualquer imagem no Scriptcase 8, elas ficam disponíveis no novo gerenciador de imagens.
Você pode acessar o gerenciador no menu Layout>Gerenciador de Imagens.

Neste gerenciador, ao localizar a imagem desejada, basta clicar com o botão direito sobre a imagem e selecionar a opção copiar endereço da imgem.
Você terá um caminho parecido com este:
IP:porta/scriptcase/devel/conf/grp/Testes_bugs/img/ico/botao_home.jpg

Em seguida basta incluir o caminho do parâmetro correto da macro, lembrando de voltar as pastas corretamente.

O código que foi enviado aparentemente esta correto, a única alteração aparente seria no caminho da imagem, que ficaria desta forma.
../../../../devel/conf/scriptcase/img/ico/botao_home.jpg

Atenciosamente,
Equipe Netmake.
Álvaro Moura.
Equipe Scriptcase

renatovdemoura

  • Iniciante
  • **
  • Mensagens: 72
    • Email
Re:Problema com Imagem na macro sc_appmenu_add_item
« Responder #2 Online: Setembro 24, 2014, 10:07:40 am »
Alvaro,

Vlw cara. a bronk era exatamente a qtd da volta das pastas que estava com 1 a menos. Funcionou corretamente.

Obg.