Autor Tópico: [RESOLVIDO] V8 - Módulo de Segurança  (Lida 899 vezes)

Celso R.

  • Expert
  • *****
  • Mensagens: 941
[RESOLVIDO] V8 - Módulo de Segurança
« Online: Agosto 30, 2014, 09:13:18 pm »
Ao gerar o módulo de segurança do meu projeto acontece o seguinte erro ao acessar aplicação Grupos/Aplicação:
Fatal error: Call to a member function Execute() on a non-object in C:\NetMake\v8\wwwroot\scriptcase\app\control_caixa\seg_appp_form_sec_groups_apps\seg_appp_form_sec_groups_apps_apl.php on line 450

Linha que ocorreu o erro:
Código: [Selecionar]
      if ($rx = $this->Db->Execute($nm_select))
      {
          $y = 0;
          $nm_count = $rx->FieldCount();
          while (!$rx->EOF)
          {
                 for ($x = 0; $x < $nm_count; $x++)
                 {
                      $this->rs[$y] [$x] = $rx->fields[$x];
                 }
                 $y++;
                 $rx->MoveNext();
          }
          $rx->Close();
      }
« Última modificação: Setembro 05, 2014, 11:20:11 am por Celso R. »
Celso R.
________________________________
SC - V 8

Jean Matos

  • Expert
  • *****
  • Mensagens: 956
    • Gestão de Construtoras
    • Email
Re:[BUG] Módulo de Segurança
« Responder #1 Online: Agosto 31, 2014, 12:26:44 pm »
esse erro começou a ocorrer comigo após a ultima atualização.
MInha app de segurança vem funcionando deste a V6. Migrei pra V7 funcionou... migrei pra V8 funcionou...
o problema esta na ultima atualização do SC
Sc - 6.xxx , 7.xxx e V8
Windows Server 2008 Enterpriser 64 bits
SqlServer 2008 Express 64 bits
Sistema Integrado de Gestão de Construtoras]WaveTOR - Sistema Integrado de Gestão de Construtoras
Teófilo Otoni - MG
(33)8824-2775

Celso R.

  • Expert
  • *****
  • Mensagens: 941
Re:[BUG] Módulo de Segurança
« Responder #2 Online: Agosto 31, 2014, 03:51:10 pm »
Como diria meu amigo "Suspeitei desde do princípio".
Valeu Jean pelo consolo.
Na real não estou conseguindo fazer nada com a V8 tudo que vou fazer dá um pau.
Celso R.
________________________________
SC - V 8

Yuri Esteves

  • Administrator
  • Expert
  • *****
  • Mensagens: 818
    • Email
Re:[BUG] Módulo de Segurança
« Responder #3 Online: Setembro 01, 2014, 11:20:45 am »
Prezados,

O problema ocorre quando se utiliza a macro sc_lookup nos eventos "OnApplicationInit".

Se você comentar o código no evento, a aplicação "form_sec_groups_apps" irá funcionar. O código é usado para exibir o valor do grupo no cabeçalho.

A correção deste problema sairá na próxima release.

Agradeço a colaboração de todos!

Celso R.

  • Expert
  • *****
  • Mensagens: 941
Re:[BUG] Módulo de Segurança
« Responder #4 Online: Setembro 01, 2014, 11:28:57 am »
Conforme recomendado pelo Sr. Yuri Funcionou.
Aguardaremos a correção por completo desse BUG.
Celso R.
________________________________
SC - V 8

Jean Matos

  • Expert
  • *****
  • Mensagens: 956
    • Gestão de Construtoras
    • Email
Re:[BUG] Módulo de Segurança
« Responder #5 Online: Setembro 01, 2014, 03:23:07 pm »
//$str_sql = "SELECT description FROM dbo.seguranca_groups WHERE group_id = ".[group];
//sc_lookup(rs, $str_sql);
//[group] = {rs}[0][0];

resolvido...
Sc - 6.xxx , 7.xxx e V8
Windows Server 2008 Enterpriser 64 bits
SqlServer 2008 Express 64 bits
Sistema Integrado de Gestão de Construtoras]WaveTOR - Sistema Integrado de Gestão de Construtoras
Teófilo Otoni - MG
(33)8824-2775

Yuri Esteves

  • Administrator
  • Expert
  • *****
  • Mensagens: 818
    • Email
[RESOLVIDO] - Módulo de Segurança
« Responder #6 Online: Setembro 05, 2014, 09:53:14 am »
Prezados,

O problema foi corrigido na release 8.000.07.

Versão já disponivel para download e atualização.