Autor Tópico: SC71 - instalação manual - erro ao instalar  (Lida 1297 vezes)

hely.sousa

  • Novato
  • *
  • Mensagens: 8
    • Email
SC71 - instalação manual - erro ao instalar
« Online: Junho 03, 2014, 03:55:55 pm »
Caros,

Contratei um virtualhost CentOS release 6.5 (Final)  para desenvolvimento das minhas aplicações. Fiz a instalação automática com sucesso na porta 98, mas gostaria de ter apenas um apache na porta 80 (já instalado anteriormente). Iniciei a instalação de todos os pre-requisitos para a versão PHP 5.4.28. Quando executo php -v obtenho:
PHP 5.4.28 (cli) (built: May  2 2014 19:34:24)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend Guard Loader v3.3, Copyright (c) 1998-2013, by Zend Technologies
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies


Bibliotecas instaladas: GD, mbstring, zend guard loader, zend OPcache, zip.

Quando tento acessar a tela de configuração da instalação recebo a seguinte mensagem:

Este scriptcase é criptografado para uma versão diferente do php.
Sua versão do PHP é 5.4.28, por favor verifique o tutorial para saber como atualizar o seu php.
Ou faça download de uma versão do scriptcase apropriada para o seu ambiente.


Os procedimentos que encontrei eu já executei, alguma dica de como prosseguir?


hely.sousa

  • Novato
  • *
  • Mensagens: 8
    • Email
Re:SC71 - instalação manual - erro ao instalar
« Responder #1 Online: Junho 03, 2014, 04:32:40 pm »
Executando o diagnosis.php identifiquei que estava com problema no ZendId. Pesquisando o forum encontrei a página http://suporte.scriptcase.com.br/index.php?/Knowledgebase/Article/View/218/0/permissao-zendid que mostra como resolver o problema.

Agora vou corrigir o problema relacionado a permissão do scriptcase ScriptCase write permission.

hely.sousa

  • Novato
  • *
  • Mensagens: 8
    • Email
Re:SC71 - instalação manual - erro ao instalar
« Responder #2 Online: Junho 03, 2014, 04:58:21 pm »
Para resolver o problema ScriptCase write permission executei o seguinte comando:

chwon apache:apache -R /var/www/scriptcase/v71/wwwroot

O resultado do diagnosis.php agora mostra que está tudo ok, mas ainda não consigo executar o scriptcase, que continua apresentando a mensagem de erro que inclui no post inicial.

Alguma ideia do que pode estar ocorrendo?

Estou usando o ScriptCase Prod: 7.1.021 Build 8
« Última modificação: Junho 03, 2014, 05:36:58 pm por hely.sousa »

hely.sousa

  • Novato
  • *
  • Mensagens: 8
    • Email
Re:SC71 - instalação manual - erro ao instalar
« Responder #3 Online: Junho 17, 2014, 12:43:49 pm »
Outro potencial problema que identifiquei estava relacionado à falta de permissão para sessões serem persistidas. Fiz o script php abaixo e tudo funcionou, desta forma descartei esta possibilidade:

[root@buriti wwwroot]# cat sessiontest.php
<?php
session_start();
$_SESSION['favcolor'] = 'green';
echo "Ok, tudo funcionando. favcolor = ". $_SESSION['favcolor'];
?>

Resultado na tela:

Ok, tudo funcionando. favcolor = green