Autor Tópico: Scriptcase 7.1 para ambiente PHP 5.4  (Lida 4691 vezes)

John L. Santos

  • Bug Tracker Team
  • Administrator
  • Expert
  • *****
  • Mensagens: 595
    • Email
Scriptcase 7.1 para ambiente PHP 5.4
« Online: Novembro 05, 2013, 08:47:49 am »
Prezados,

Atualmente estamos trabalhando para liberar a próxima atualização do Scriptcase 7.1 com uma grande novidade, o PHP versão 5.4 e com muitas correções.
É possível que vocês se deparem com o serviço temporariamente indisponível, pedimos desculpas por qualquer transtorno, estaremos sempre melhorando nossos serviços e produto.
« Última modificação: Novembro 05, 2013, 08:50:29 am por John L. Santos »
John L. Santos
NetMake - Soluções em Informática

Jocimar

  • Expert
  • *****
  • Mensagens: 619
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #1 Online: Novembro 05, 2013, 08:55:48 am »
John,

Ao finalizar toda a empreitada, avise-nos!

Att,

Jocimar
Jocimar de Oliveira

Maurélio

  • Avançado
  • ****
  • Mensagens: 304
  • O eterno Aprendiz.'.
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #2 Online: Novembro 06, 2013, 03:04:41 pm »
Olá John,

Fico contente em saber da nova atualização.

Só uma pergunta. E quem estiver usando o PHP 5.3.x no ambiente de produção, ainda será compatível?

Pergunto isto pois alguns clientes rodam o sistema em servidores de hospedagem e este só possui o PHP5.3.x.

Como vai ficar?

Continuará funcionando ou não?

[]´s
MA
Marco Aurélio

chaia

  • Novato
  • *
  • Mensagens: 18
  • Nunca pare de Sonhar e Trabalhar.
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #3 Online: Novembro 06, 2013, 10:16:47 pm »
Olá John,

Fico contente em saber da nova atualização.

Só uma pergunta. E quem estiver usando o PHP 5.3.x no ambiente de produção, ainda será compatível?

Pergunto isto pois alguns clientes rodam o sistema em servidores de hospedagem e este só possui o PHP5.3.x.

Como vai ficar?

Continuará funcionando ou não?

[]´s
MA


Ótima pergunta, tb gostaria de saber esta resposta.
Abs.
Chaia

jorgepopel

  • Expert
  • *****
  • Mensagens: 568
    • iCentro Tecnologia e Sistemas
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #4 Online: Novembro 06, 2013, 11:06:03 pm »
Também espero uma resposta positiva, senão de nada adianta.

nelson machado

  • Novato
  • *
  • Mensagens: 11
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #5 Online: Novembro 07, 2013, 12:47:00 am »
http://epvhost.com.br/scriptcase/tmp/sc_diagnosis_20131107012947.html

ao tentar fazer upgrade depois que lancaram a versao para php5.4 passou a acontecer este erro

Realizando Backup dos Arquivos de usuário do ScriptCase...
Fatal error: Uncaught exception 'UnexpectedValueException' with message 'RecursiveDirectoryIterator::__construct(/var/www/scriptcase/devel/conf/sys/lib/config) [<a href='recursivedirectoryiterator.--construct'>recursivedirectoryiterator.--construct</a>]: failed to open dir: Permission denied' in /var/www/scriptcase/devel/lib/php/functions.inc.php:5388 Stack trace: #0 [internal function]: RecursiveDirectoryIterator->__construct('/var/www/script...', 0) #1 /var/www/scriptcase/devel/lib/php/functions.inc.php(5388): RecursiveDirectoryIterator->getChildren() #2 /var/www/scriptcase/devel/class/page/nmPageAdminUpdate.class.php(842): nmBackupUserFiles(1) #3 /var/www/scriptcase/devel/class/page/nmPageAdminUpdate.class.php(305): nmPageAdminUpdate->HandleStep() #4 /var/www/scriptcase/devel/class/page/nmPage.class.php(2419): nmPageAdminUpdate->DisplayContent() #5 /var/www/scriptcase/devel/class/page/nmSite.class.php(96): nmPage->Display() #6 /var/www/scriptcase/devel/lib/php/base_ini.inc.php(1252): nmSite->Run() #7 /var/www/scriptcas in /var/www/scriptcase/devel/lib/php/functions.inc.php on line 5388

paulomarcelo

  • Expert
  • *****
  • Mensagens: 638
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #6 Online: Novembro 07, 2013, 07:46:55 am »
Muito bom, esta release, pois nota a preocupação de manter a ferramenta scriptcase sempre atualizada no php mais estável e isso é muito importante pois como o php é a base do scriptcase nós ganhamos com isso as correções e melhorias que a versão 5.4 traz. Vai dar um trabalho pois tem que configurar os ambientes mas vale a pena. Uma pergunta pode ser usado o mesmo ambiente de produção da release anterior ou tem que atualizar também.

John L. Santos

  • Bug Tracker Team
  • Administrator
  • Expert
  • *****
  • Mensagens: 595
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #7 Online: Novembro 07, 2013, 08:04:12 am »
Olá John,

Fico contente em saber da nova atualização.

Só uma pergunta. E quem estiver usando o PHP 5.3.x no ambiente de produção, ainda será compatível?

Pergunto isto pois alguns clientes rodam o sistema em servidores de hospedagem e este só possui o PHP5.3.x.

Como vai ficar?

Continuará funcionando ou não?

[]´s
MA
Ótima pergunta, tb gostaria de saber esta resposta.
Abs.
Chaia
Também espero uma resposta positiva, senão de nada adianta.

Prezados,

Estamos disponibilizando os pacotes .ZIP e .TGZ compatíveis com o PHP 5.3, além de que, também continua sendo possível uma atualização automática para quem possui o antigo ambiente.

http://www.scriptcase.com.br/baixar-scriptcase/
John L. Santos
NetMake - Soluções em Informática

John L. Santos

  • Bug Tracker Team
  • Administrator
  • Expert
  • *****
  • Mensagens: 595
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #8 Online: Novembro 07, 2013, 08:12:02 am »
http://epvhost.com.br/scriptcase/tmp/sc_diagnosis_20131107012947.html

ao tentar fazer upgrade depois que lancaram a versao para php5.4 passou a acontecer este erro

Realizando Backup dos Arquivos de usuário do ScriptCase...
Fatal error: Uncaught exception 'UnexpectedValueException' with message 'RecursiveDirectoryIterator::__construct(/var/www/scriptcase/devel/conf/sys/lib/config) [<a href='recursivedirectoryiterator.--construct'>recursivedirectoryiterator.--construct</a>]: failed to open dir: Permission denied' in /var/www/scriptcase/devel/lib/php/functions.inc.php:5388 Stack trace: #0 [internal function]: RecursiveDirectoryIterator->__construct('/var/www/script...', 0) #1 /var/www/scriptcase/devel/lib/php/functions.inc.php(5388): RecursiveDirectoryIterator->getChildren() #2 /var/www/scriptcase/devel/class/page/nmPageAdminUpdate.class.php(842): nmBackupUserFiles(1) #3 /var/www/scriptcase/devel/class/page/nmPageAdminUpdate.class.php(305): nmPageAdminUpdate->HandleStep() #4 /var/www/scriptcase/devel/class/page/nmPage.class.php(2419): nmPageAdminUpdate->DisplayContent() #5 /var/www/scriptcase/devel/class/page/nmSite.class.php(96): nmPage->Display() #6 /var/www/scriptcase/devel/lib/php/base_ini.inc.php(1252): nmSite->Run() #7 /var/www/scriptcas in /var/www/scriptcase/devel/lib/php/functions.inc.php on line 5388

Olá Sr. Nelson,

Como o próprio erro descreve, o problema ocorre devido a ausência de permissão para acessar diretórios da pasta do Scriptcase. Peço que o senhor dê as devidas permissões para a toda a pasta do Scriptcase e tente novamente.

Para servidores locais:

# chmod -R 777 /scriptcase

Para servidores WEB:

# chmod -R 755 /scriptcase


Também posso recomendá-lo a realizar uma atualização manual do Scriptcase. É rápido e simples, basta fazer o download em nosso site do Scriptcase compactado. O senhor deverá descompactar os arquivos na sua pasta do Scriptcase. Veja este tutorial:

https://suporte.scriptcase.com.br/index.php?/Knowledgebase/Article/View/66/0/atualizacao-manual---versao-7
John L. Santos
NetMake - Soluções em Informática

John L. Santos

  • Bug Tracker Team
  • Administrator
  • Expert
  • *****
  • Mensagens: 595
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #9 Online: Novembro 07, 2013, 08:31:07 am »
Muito bom esta release, pois nota a preocupação de manter a ferramenta scriptcase sempre atualizada no php mais estável e isso é muito importante pois como o php é a base do scriptcase nós ganhamos com isso as correções e melhorias que a versão 5.4 traz. Vai dar um trabalho pois tem que configurar os ambientes mas vale a pena. Uma pergunta pode ser usado o mesmo ambiente de produção da release anterior ou tem que atualizar também.

Olá Sr. Paulo,

O senhor pode sim utilizar o mesmo ambiente de produção da atualização anterior, porém é recomendável que o atualize, pois houveram atualizações na base de CEP.
John L. Santos
NetMake - Soluções em Informática

marciogrulke

  • Iniciante
  • **
  • Mensagens: 80
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #10 Online: Novembro 07, 2013, 04:47:44 pm »
uso windows 2003, sql server 2005


removi versão anterior 7.1.09 e instalei esta versão nova mas SC não reconhece banco de dados de forma alguma da seguinte erro
quando tento gerar da seguinte erro:


o módulo do PHP responsável pela conexão com bases de dados mssql não está carregado. | Script: C:\Arquivos de programas\NetMake\v71\wwwroot\scriptcase\devel\compat\nm_select.class.php linha: 100

quando tento criar uma conexão da erro....

olhei php.ini extensão mssql esta ok habilitada

o que pode estar ocorrendo?
Modificar mensagem

marciogrulke

  • Iniciante
  • **
  • Mensagens: 80
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #11 Online: Novembro 07, 2013, 04:51:14 pm »
isto esta ocorrendo com versão saiu agora acabei instalar, 7.1.0.10 esta versão não esta reconhecendo ou criando ligação banco de dados deve ser alguma configuração no php mas sou meio leigo o que devo fazer a extensao mssql esta ativa

não consigo nen criar uma conexão nova e projetos de fiz restauração dão erro ao gerar....

meu serviço passou servidor esta fora ar cliente esta na minha cola não sei fazer!!


me ajudem eu uso windows 2003 com ms sql 2005


obrigado...

pessanha

  • Expert
  • *****
  • Mensagens: 643
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #12 Online: Novembro 07, 2013, 08:32:19 pm »
Acabei de instalar o SC7.1.0010 e estou com esta tela, nao esta executando o SC.




O que fazer?

Agostinho

  • Avançado
  • ****
  • Mensagens: 277
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #13 Online: Novembro 07, 2013, 08:53:38 pm »
Pesanha, isto tambem ocorreu comigo, por pouco não perdi tudo que eu tinha, a minha sorte foi que salvei a pasta inteiro da versao anterior, senao tava perdido, e ainda nao consegui fazer funcionar, mesmo fazendo uma instalação nova no linux. Por enquanto instalei no windows para pode trabalhar, mas quero voltar a colocar o SC no linux novamente.

pessanha

  • Expert
  • *****
  • Mensagens: 643
    • Email
Re:Scriptcase 7.1 para ambiente PHP 5.4
« Responder #14 Online: Novembro 07, 2013, 08:57:33 pm »
fiz o backup, mas estou sem poder rodar o SC... nao sei o que fazer, estou usando o windows 8
« Última modificação: Novembro 07, 2013, 08:59:11 pm por pessanha »