Autor Tópico: Ao publicar o usuário Admin perde acesso específicos!  (Lida 798 vezes)

FredKeyster

  • Expert
  • *****
  • Mensagens: 1702
  • DEWENNINMEN
    • Email
Ao publicar o usuário Admin perde acesso específicos!
« Online: Setembro 09, 2013, 06:30:35 pm »
Pessoal, acabei de publicar um projeto onde o mesmo tem apenas um usuário! (Primeiro projeto da versão 7.1)

Este usuário tem acesso total em todas as aplicações do projeto, isso quando estou em ambiente de desenvolvimento.
Após publicar, o Admin perde vários acessos! Inclusive o acesso do App configuração, onde é o local que dou permissão total aos usuários. Isso é Bug? É algo errado na publicação (publicação típica)? Alguém já teve algo semelhante? Como resolver?

Abraço a todos!
F. A.
Analista de Sistemas

saulobborges

  • Expert
  • *****
  • Mensagens: 1392
    • SGi Sistemas
    • Email
Re:Ao publicar o usuário Admin perde acesso específicos!
« Responder #1 Online: Setembro 09, 2013, 09:18:21 pm »
Você sincronizou as aplicações e definiu os direitos do grupo ou usuário corretamente ?

Almeida

  • Expert
  • *****
  • Mensagens: 610
    • Email
Re:Ao publicar o usuário Admin perde acesso específicos!
« Responder #2 Online: Setembro 09, 2013, 10:23:16 pm »
Pessoal, acabei de publicar um projeto onde o mesmo tem apenas um usuário! (Primeiro projeto da versão 7.1)

Este usuário tem acesso total em todas as aplicações do projeto, isso quando estou em ambiente de desenvolvimento.
Após publicar, o Admin perde vários acessos! Inclusive o acesso do App configuração, onde é o local que dou permissão total aos usuários. Isso é Bug? É algo errado na publicação (publicação típica)? Alguém já teve algo semelhante? Como resolver?

Abraço a todos!

Fred, eu acho que seu SC está marcado para não usar segurança, ai no desenvolvimento vê todas as aplicações existente...
Eu no meu módulo de segurança, verifico se o usuário que está logado é o admin, se for faço a liberação de todas as apps, lendo a pasta e liberando. Para ficar mais fácil, pode colocar apenas os módulos de segurança para liberar quando for o admin logado, pela macro sc_apl_status(app, ON);

Att.
Eliezer Almeida
eliezeralmeidago@hotmail.com
www.infotecsoft.com.br - Modernidade e Eficiência

FredKeyster

  • Expert
  • *****
  • Mensagens: 1702
  • DEWENNINMEN
    • Email
Re:Ao publicar o usuário Admin perde acesso específicos!
« Responder #3 Online: Setembro 10, 2013, 09:54:50 am »
Você sincronizou as aplicações e definiu os direitos do grupo ou usuário corretamente ?

Olá Saulo, eu sincronizei sim, mas o problema estava no banco.

Citar
Fred, eu acho que seu SC está marcado para não usar segurança, ai no desenvolvimento vê todas as aplicações existente...

Na verdade esta marcado para usar sim, acabei resolvendo da seguinte maneira.

No banco de dados na tabela "sec_groups_app" eu dei um Truncate (Isso no bando de publicação)  depois peguei os dados do banco de desenvolvimento e importei para essa tabela. Funcionou!

Problema tava no banco! Obrigado meus irmãos!
F. A.
Analista de Sistemas