Autor Tópico: Problema em IIS + Aplicaçao em servidor na rede. Nao é em servidor web!  (Lida 5125 vezes)

Alekiz

  • Visitante
Olá,
Estou tentando publicar uma aplicaçao que fiz em um servidor que tenho aqui na rede, para que seja um sistema tipo intranet.
Tenho o IIS instalado no servidor. Executei os passos conforme o tutorial de publicaçao, gerei o zip, descompactei, coloquei na pasta wwwroot... baixei o ambiente de produçao do site, descompactei tambem la no wwwroot, dei permissao de acesso para leitura e gravaçao pelo IIS, entrei nas configuraçoes de segurança da pasta e tambem liberei controle total para todos usuários.
O servidor é um Windows 2003 Server.
Após descompactar o zip e o prod na pasta wwwroot do servidor, fui tentar acessar o prod para poder configurar as conexoes, porém, me retorna o erro "Não é possível localizar a página" mas o caminho está correto, pois coloquei uma pagina qualquer dentro da prod, só para testar, e o browser acessa normalmente.
Inclusive na barra de endereço do browser, eu digito apenas http://192.168.0.50/scriptcase/prod pois 192.168.0.50 é o IP do meu servidor, e /scriptcase/prod é o caminho criado dentro de wwwroot.. e apos tentar acessar esse endereço o browser altera automaticamente o endereço para http://192.168.0.50/scriptcase/prod/index.php, ou seja, ele encontrou o index.htm e o index.php.. verifiquei tambem que o index.php redireciona para outro .php na pasta lib, ja verifiquei se esse arquivo existia e tinha permissao, e estava tudo OK.

Outra coisa que percebi tambem, é que quando tento acessar o meu sistema, ao inves de dar o erro de que nao existe banco de dados configurado, aparece o erro "Listagem de diretório negada
Este diretório virtual não permite que o conteúdo seja listado."
Eu ja coloquei permissao total na configuraçao das pastas, mas mesmo assim nao acessa.
Converso no suporte mas só me dizem para seguir o tutorial denovo, para baixar o prod.. mas nenhuma das respostas fez com que resolvesse meu problema.

Acredito que é alguma configuraçao no IIS, ou no proprio windows 2003 que eu sei que é mais chato nessa questao de acessos, alguem tem alguma sugestao?


PS: Esse servidor é onde eu instalei o ScriptCase. Porem nao instalei nele Apache, nem o PHP em si, nem o IIS. O IIS ja estava la, só configurei ele.

Rodrigo Lins

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 504
    • Overalt I.T
Re: Problema em IIS + Aplicaçao em servidor na rede. Nao é em servidor web!
« Responder #1 Online: Outubro 03, 2008, 09:07:38 am »
O primeiro passo para conseguir fazer funcionar no IIS ScriptCase ou Ambiente de Produção ou qualquer outra página feita em PHP, é ter o PHP configurado no IIS.

Por padrão, o IIS não funciona com páginas em PHP.

Primeira coisa será fazer funcionar o PHP, tente ver se pelo menos o 'info.php' funciona.

Neste link a seguir explica como fazer a instalação do ScriptCase no IIS6, são os mesmos passos para o Ambiente de Produção.

 http://www.netmake.com.br/site/baseknowledge/baseknowledge.php?id_topico=96

Espero ter ajudado.

Rodrigo Lins.