Autor Tópico: Problema com Aspas Duplas na Edição de Templates  (Lida 1294 vezes)

Daves Vieira

  • Novato
  • *
  • Mensagens: 44
    • Email
Problema com Aspas Duplas na Edição de Templates
« Online: Agosto 29, 2013, 07:23:13 pm »
Boa noite,

Não consigo usar aspas simples ou duplas na edição de templates do Scriptcase (Ferramentas > Layout > Templates).

Se tento gravar a informação <font face="Arial"> ele me retorna <font face=\"Arial\"> e dessa maneira eu não posso criar um template utilizando aspas simples ou duplas nas tags.

Alguém pode me ajudar ?

Estou utilizando a versão 7.01.0005
« Última modificação: Agosto 29, 2013, 07:27:56 pm por daves.vieira »

Allan Medeiros

  • Expert
  • *****
  • Mensagens: 504
    • Email
Re:Problema com Aspas Duplas na Edição de Templates
« Responder #1 Online: Agosto 31, 2013, 12:22:27 pm »
Desculpe a pergunta, mas qual o seu grau de conhecimento em PHP?
Destro das strings em PHP, quando vc quer usar aspas no conteúdo, você coloca uma contrabarra (\) antes dela.
Ou seja:
echo "Isto é uma aspa dupla \" e isso é uma aspa simples \' . ";
Irá exibir :
Isto é uma aspa dupla " e isso é uma aspa simples ' .

No seu caso: <font face=\"Arial\"> exibirá na aplicação: <font face="Arial">

[]s
Allan Medeiros
Analista de Informática
__________________________________________
Companhia de Processamento de Dados da Paraíba
medeiros@codata.pb.gov.br

Haroldo

  • Expert
  • *****
  • Mensagens: 6264
  • Conhecimento diminui limitações.△TFA△
    • Infinitus Web Gestão Empresarial/Gestão ITIL/Consultoria Scriptcase
Re:Problema com Aspas Duplas na Edição de Templates
« Responder #2 Online: Agosto 31, 2013, 05:56:48 pm »
Não seria Ferramentas->Visualização->Templates?


Olhe os exemplos já existentes e siga o padrão.

Daves Vieira

  • Novato
  • *
  • Mensagens: 44
    • Email
Re:Problema com Aspas Duplas na Edição de Templates
« Responder #3 Online: Setembro 01, 2013, 11:16:42 pm »
Alan, isso eu sei ... Mas va explicar isso pro editor de templates ;) ... Tentei fazer isso mas mesmo assim não funciona.

Haroldo, nao existe esse VISUALIZAÇÃO na versao 7 não .... É Ferramentas > Layout > Templates mesmo. Eu olhei os modelos, copiei um, colei e salvei. Pedi pra visualizar e aconteceu a mesma coisa.

A única maneira que funcionou bem foi criando um novo template (cabeçalho) e anexando um arquivo com o código. Mas usando o editor, ele nao funciona com as aspas.

Se puderem, façam um teste por aí e me avisem se conseguiram.