Autor Tópico: N-N Relations (delete)  (Lida 836 vezes)

adriano.nogueira

  • Iniciante
  • **
  • Mensagens: 89
    • Email
N-N Relations (delete)
« Online: Agosto 02, 2013, 08:59:36 am »
Bom dia.
   Não sei se alguém se deparou com esse erro. Eu tenho um N-N Relations que funciona certinho, só que de uma hora pra outra ele para de funcionar da seguinte forma... em modo debug, ele faz os insert´s só que depois tem um linha de delete... que não sei de onde apareceu esse comando, pois não tem configuração que faz isso eu creio.
   Para resolver, tenho que criar o campo novamente. Alguém sabe dessa solução ou desse DELETE que acontece depois ?
Obrigado.
Adriano

MFM

  • Novato
  • *
  • Mensagens: 25
Re:N-N Relations (delete)
« Responder #1 Online: Outubro 09, 2013, 10:40:40 am »
Estou com o mesmo problema.

No modo de inclusão funciona perfeitamente.

No modo de atualização não funciona. Analisando o modo debug, dá pra ver que os inserts na "tabela filha" são feitos corretamente. Mas depois é excutado um delete que apaga os inserts que foram feitos!

Acho que o certo seria que o delete executasse primeiro e depois os inserts...

adriano.nogueira

  • Iniciante
  • **
  • Mensagens: 89
    • Email
Re:N-N Relations (delete)
« Responder #2 Online: Outubro 10, 2013, 04:45:41 pm »
MFM, boa tarde.
    Esse problema comigo foi resolvido.
    O meu caso era: No mesmo formulário eu tinha 2 campos N-N apontando para a mesma tabela, porém utilizando parâmetros diferentes. Então o que acontecia... ele inseria o registro e logo depois apagava, porque no outro campo estava vazio.
    A solução foi colocar cada campo em ABAS diferente... resolveu 100%.
    Fica aí a dica.
At.
Adriano

MFM

  • Novato
  • *
  • Mensagens: 25
Re:N-N Relations (delete)
« Responder #3 Online: Outubro 14, 2013, 10:04:12 am »
adriano.nogueira,

Esse é o meu caso também, mais de um campo N-N no mesmo formulário que aponta pra mesma tabela.

No meu caso vou ter que criar 4 abas...

Valeu pela dica.