Autor Tópico: Problemas com filtro  (Lida 1293 vezes)

kllleberson

  • Novato
  • *
  • Mensagens: 4
    • Email
Problemas com filtro
« Online: Agosto 02, 2008, 07:12:33 am »
Sou usuário com pouca experiencia no Scriptcase. Fiz o treinamento com o pessoal da Netmake da versão 3 porém já adquiri a versão 4.

Estou passando por uma dificuldade com a criação de filtros com a ligação para outra aplicação. Criei um Filtro pelo campo nome (por exemplo) e realizei uma ligação com o formulário de Cadastro de Pessoas. O campo nome do filtro é do tipo Texto Auto Complete. Em algumas vezes, quando seleciono um dos nomes mostrados na tela, o filtro chama o form de cadastro na primeira posição no modo de edição. Outras vezes chama a tela de cadastro no modo de inclusão. A principio nao consegui isolar o critério desta caracteristica.

O engraçado é que na mesma aplicação eu tenho outro filtro, que desta vez faz a busca pelo campo código (numérico auto complete) e este funciona perfeitamente.

Gostaria da ajuda do pessoal do fórum.

Rodrigo Lins

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 504
    • Overalt I.T
Re: Problemas com filtro
« Responder #1 Online: Agosto 08, 2008, 12:02:32 pm »
Bom Dia,

Quando acontece de filtrarmos um campo e aplicação vir para "Inclusão" é quando o registro não existe na base de dados, então, ele entende isso e disponibiliza a inclusão do mesmo.

No caso do Auto-Complete, obrigatoriamente precisamos ir digitando e selecionar na caixa o que nos retorna para ele fazer o filtro corretamente, se por exemplo, o senhor digitar "rodrigo" sem clicar depois na caixa do auto-complete (do que foi retornado) ele não irá reconhecer o resultado e virá como inclusão.

Espero ter esclarecido de alguma forma a dúvida.

Atenciosamente,

Rodrigo Lins.