Autor Tópico: [RESOLVIDO] Problema com consulta - pré filtro  (Lida 937 vezes)

mrcgomes

  • Intermediário
  • ***
  • Mensagens: 223
    • Email
[RESOLVIDO] Problema com consulta - pré filtro
« Online: Abril 06, 2013, 11:47:08 am »
Olá, é meu primeiro post neste fórum, pois adquiri recentemente o ScriptCase.

Eu estou com a seguinte situação:
Eu tenho uma "Consulta" onde eu aplico um pré-filtro no SQL para exibir apenas os registros "Pendentes". Nesta consulta tenho uma ligação para atualização deste status em outra tela. Pois bem funciona perfeitamente, mas eu não consigo utilizar "Pesquisa" para pesquisar outros status.
Ele está aplicando o pré-filtro feito ao abrir o Grid de Consulta.
Alguém sabe como resolver isso?

Obrigado
Marcelo
« Última modificação: Abril 07, 2013, 01:48:23 am por Bernhard »

Jailton

  • Expert
  • *****
  • Mensagens: 2040
Re:Problema com consulta - pré filtro
« Responder #1 Online: Abril 06, 2013, 02:38:31 pm »
Primeiro você vai tirar o pré-filtro do SQL.

Entrar em Consulta > Configuração
habilitar o CheckBox Filtro

Iniciar pelo Filtro

Depois vai em Filtro > Posicionamento dos Campos, escolhe o Campo STATUS da sua base e outros que desejar fazer o filtro.

Entra em Condições do Filtro Escolhe Status > Limpar Todos ** Ai clica em Exatamente Igual Habilita

Ai clica em Filtro no Campo > Status e Seleciona DUPLO SELECT
Neste DUPLO SELECT você vai adicionar manualmente ou fazer a SQL que define os STATUS que ele vai filtrar.

** Pronto agora é só testar.
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.

mrcgomes

  • Intermediário
  • ***
  • Mensagens: 223
    • Email
Re:Problema com consulta - pré filtro
« Responder #2 Online: Abril 06, 2013, 06:36:58 pm »
Jailton
Funcionou. Valeu pela ajuda.
Marcelo