Autor Tópico: não gera PDF  (Lida 6748 vezes)

egon01

  • Visitante
não gera PDF
« Online: Abril 28, 2008, 05:30:04 pm »
meu sistema está publicado, bombando... em linux, num provedor
porem, não consigo gerar pdf
quando vou gerar o pdf dá a seguinte mensagem,

"""Gerando PDF...
O Arquivo no formato pdf não pode ser gerado. Contate o administrador do sistema.
Para maiores informações, consulte: www.scriptcase.com.br/site/support/htmldoc_pt_br.html  """

 mas a barra de rolagem, acima desta mensagem, vai a a 100%

bom entrei no site, li e fiz tudo, permissoes etc e tal, acontece que neste site fala muito num tal de:  ..\scriptcase\prod\third\htmldoc e ai dentro um tal de htmldoc24 executavel (imagino!) e no meu aparece htmldoc26, pode ser isso???
marcia
 

egon01

  • Visitante
Re: não gera PDF
« Responder #1 Online: Abril 28, 2008, 05:38:18 pm »
detalhe: baixei do site da netmake o arquivo de produção pra linux e da versão 3!!

Ricardão

  • Novato
  • *
  • Mensagens: 30
Re: não gera PDF
« Responder #2 Online: Maio 08, 2008, 09:33:08 pm »
Marcia, eu tive o mesmo problema e bastou atribuir todas as permissões para o arquivo htmldoc26 e para o htmldoc26.exe  que deu certo.

Espero ter ajudado... Abraço

renan_andrade

  • Visitante
Re: não gera PDF
« Responder #3 Online: Maio 12, 2008, 09:51:10 am »
É isso mesmo, basta as permissões para funcionar... mas procure revisar as coisas mais lógicas...:

Seu ambiente de produção é da versão 3, neste caso existem dois um para linux e outro para windows.

Aplicações da versão 3 funcionam com o ambiente de produção da versão 3 e aplicações da versão 4 com o ambiente de produção da versão 4.

até logo!

egon01

  • Visitante
Re: não gera PDF
« Responder #4 Online: Maio 12, 2008, 05:08:01 pm »
gente, eu estava verificando o tal htmldoc26, e somente achei um arquivo htmldoc26, que diz ser binario, e não achei nenhum htmldoc26.exe
to viajando????
márcia

egon01

  • Visitante
Re: não gera PDF
« Responder #5 Online: Maio 12, 2008, 09:19:02 pm »
renan???
assim, meu ambiente de desenvolvimento é a versão 3, de produção é versão 3 para linux , o arquivo que baixei do site na netmake é o scriptcase3-linux-prod-3.0.156-pt_br.zip, olhei este zip e nele não tem htmldoc26.exe , somente um tal de htmldoc26 sem extensão, não sei o que é,
o que to fazendo de errado??? achei um tal de htmldoc26.exe em outros endereços na minha maquina, mas para win, copie para o provedor linux, para a pasta \third\htmldoc\ mas não resolveu
please, to enrolada

renan_andrade

  • Visitante
Re: não gera PDF
« Responder #6 Online: Maio 20, 2008, 11:21:08 am »
Você baixou o prod do linux, por isso não tem o '.exe' está correto!

egon01

  • Visitante
Re: não gera PDF
« Responder #7 Online: Maio 20, 2008, 05:44:10 pm »
ok renan, se baixei o prod pra linux, e não precisa o htmldoc26.exe, pq não funciona???
todos os arquivos estão com permissoes

''O Arquivo no formato pdf não pode ser gerado. Contate o administrador do sistema.
Para maiores informações, consulte: www.scriptcase.com.br/site/support/htmldoc_pt_br.html ''
 e pq essa pagina ai não abre mais?? e pq nesta pagina não dizia que não precisava do .exe???
 alias mandava compila sei lá o que, agora não consigo mais ver!!
mas é impossivel que todo mundo que tenha publica em linux consiga gerar PDF, menos eu, certo?
alguma coisa ta errada, talvez seja comigo, mas que tá, tá!
marcia

egon01

  • Visitante
Re: não gera PDF
« Responder #8 Online: Maio 20, 2008, 05:54:21 pm »
imagino tbem que ele grave o pdf em alguma pasta,  httpdocs / prod_scriptcase / tmp
e lá tem um arquivo com o seguinte nome :

sc_pdf_20080520174753_466_pendencia10_cons.log

egon01

  • Visitante
Re: não gera PDF
« Responder #9 Online: Maio 20, 2008, 06:02:09 pm »
tem uma pasta httpdocs / prod_scriptcase / prod / third / adodb
essa pasta ai  precisa permissoes 777 recursiva tbem????

beto

  • Visitante
Re: não gera PDF
« Responder #10 Online: Junho 29, 2008, 03:19:20 pm »
É bom vc dar permissão total no ambiente de produção para que não haja problemas deste tipo.... E verifique se as permissão estão sendo herdadas nas sub-pastas.

egon01

  • Visitante
Re: não gera PDF
« Responder #11 Online: Agosto 07, 2008, 04:27:22 pm »
tudo com permissão total, pode ser problema de segurança ou algo assim do provedor??? o meu no caso é a datadrome
valeu

Rodrigo Lins

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 504
    • Overalt I.T
Re: não gera PDF
« Responder #12 Online: Agosto 08, 2008, 11:59:36 am »
Bom Dia,

Possíveis problemas para não gerar o PDF é no servidor a função "exec" do PHP estar desabilitada, confira no info.php se a opção "disable_functions" possue valores nele setados.

Outro problema que pode ocorrer é no servidor possuir a segurança chamada SELinux, que pode bloquear a execução do HTMLDOC.

O problema mais comum, é não possuir permissão no executável HTMLDOC (dentro do /prod/third/htmldoc), tente dar permissão novamente somente no executável dentro do diretório informado anteriormente.

Atenciosamente,

Rodrigo Lins.

egon01

  • Visitante
Re: não gera PDF
« Responder #13 Online: Setembro 17, 2008, 02:27:53 pm »
Rodtigo Lins??? olha, não sei o que fazer, ok??
olhem a resposta do provedor:

Histórico do chamado:
17/09/08 11:30 [Ana Scheffel]: Prezada Márcia,
A permissão total foi confirmada na pasta que nos informou. Todo o conteúdo dessa pasta se encontra também com essa permissão. O Safe mode se encontra desabilitado e com isso a função `exec` pode ser usada já.

Caso esteja ainda com problemas, sugiro verificar se há ainda alguma configuração a ser feita com o desenvolvedor do software.

Ficamo então à disposição de efetuar as modificações que se fizerem necessárias.

 

Rodrigo Lins

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 504
    • Overalt I.T
Re: não gera PDF
« Responder #14 Online: Setembro 20, 2008, 08:36:54 am »
Neste caso é interessante gerar o diagnosis deste ambiente para ser verificado as configurações.

Pois o PHP também pode estar bloqueando a função 'exec' do php.

Entre em contato com o setor de suporte da NetMake.

Se não possuir o contrato de suporte, entre com o usuário problema de instalação, pois, neste caso seria um problema com relação ao ambiente (instalação).

Desta forma será mais pratico e fácil resolver.

Rodrigo Lins.