Autor Tópico: V7 erro no sc_link [RESOLVIDO]  (Lida 1235 vezes)

Dos Santos

  • Novato
  • *
  • Mensagens: 43
    • Email
V7 erro no sc_link [RESOLVIDO]
« Online: Fevereiro 07, 2013, 08:57:09 am »
Com a mudança no php.ini resolveu o problema do cache, mas continua o problema da lentidão na geração.

E todas as aplicações que usam sc_link no onRecord com a tag _blank e funcionavam normal na V6, depois da conversão para a V7 estão com problema, apresentando a seguinte mensagem:

Parse error: syntax error, unexpected T_EXIT, expecting T_FUNCTION in C:\Program Files (x86)\NetMake\v7\wwwroot\scriptcase\app\... on line 1390

SO Win8 64
« Última modificação: Fevereiro 11, 2013, 03:08:06 pm por Dos Santos »

Yuri Esteves

  • Administrator
  • Expert
  • *****
  • Mensagens: 818
    • Email
Re:V7 erro no sc_link
« Responder #1 Online: Fevereiro 07, 2013, 09:13:37 am »
Bom dia.

Poderia informar de que maneira estas utilizando a macro no evento onrecord da consulta.

Se possivel, cole o seu codigo aqui.

Att,

Cleyton Euler

  • Expert
  • *****
  • Mensagens: 1149
    • Associação de Usuários Scriptcase
    • Email
Re:V7 erro no sc_link
« Responder #2 Online: Fevereiro 07, 2013, 01:34:37 pm »
Pela contexto e msg de erro, parece que o gerador esquece de fechar a função. Acho que é um bug.
Associação de Usuários Scriptcase
http://www.auscriptcase.com.br

Consultoria Scriptcase Versão 5
http://www.infinitusweb.com.br

Dos Santos

  • Novato
  • *
  • Mensagens: 43
    • Email
Re:V7 erro no sc_link
« Responder #3 Online: Fevereiro 07, 2013, 04:35:09 pm »
Descobri o problema !!

Na V7 não está habilitado o uso de short-tags no PHP.

Yuri Esteves

  • Administrator
  • Expert
  • *****
  • Mensagens: 818
    • Email
Re:V7 erro no sc_link
« Responder #4 Online: Fevereiro 07, 2013, 06:38:01 pm »
Prezados,

A diretiva do php "short_open_tag" é usado em relação a tag de abertura do PHP.
As versões mais novas do php, informam para usar a tag de abertura desta forma <?php ?>, provavelmente o senhor possui algum codigo que a abertura da tag não esta iniciando com o php, por isso provocou o erro.

Na proxima release, (7.0.002), estaremos Habilitando "short_open_tag"  em nosso instalador.

Agradeçemos desde já ao contato.