Autor Tópico: Acentuação Scripcase 6 Mysql  (Lida 973 vezes)

samujunior

  • Novato
  • *
  • Mensagens: 13
    • Email
Acentuação Scripcase 6 Mysql
« Online: Fevereiro 02, 2013, 09:49:08 pm »
Olá pessoal!
 
Tenho a seguinte situação: ao gerar uma consulta no ambiente de desenvolvimento, as palavras acentuadas são exibidas normalmente. O mesmo não ocorre no servidor de produção - aparecem com aqueles carecteres codificados.

Alguém já passou por esse problema? Alguma dica ou configuração necessária?

Obrigado desde já!

Robert Berbert

  • Expert
  • *****
  • Mensagens: 769
  • Desenvolver é sempre estar se atualizando.
    • Conesoft
    • Email
Re:Acentuação Scripcase 6 Mysql
« Responder #1 Online: Fevereiro 04, 2013, 01:59:14 pm »
Cara é sempre charset, pode ser no banco, nas aplicações, no texto que tá no seu banco. É realmente complicado..
-- Design ou programador eis a questão.

marcelo_miranda

  • Novato
  • *
  • Mensagens: 19
    • Email
Re:Acentuação Scripcase 6 Mysql
« Responder #2 Online: Fevereiro 04, 2013, 02:38:32 pm »
São todos os dados(dados do banco e label do scriptcase, titulos das aplicações e etc), ou somente do banco?
Se for todos, provavelmente o charset padrão deve estar utf8, faça o seguinte, tente encontrar essa linha no httpd.conf

AddDefaultCharset UTF8

altere para

#AddDefaultCharset UTF8

Veja se resolve.

Abs.
Marcelo Miranda
Contato: miranda_marcelo@outlook.com

jorgepopel

  • Expert
  • *****
  • Mensagens: 568
    • iCentro Tecnologia e Sistemas
    • Email
Re:Acentuação Scripcase 6 Mysql
« Responder #3 Online: Maio 27, 2013, 03:56:22 pm »
Coloquei uma dúvida semelhante no tópico: https://www.scriptcase.com.br/forum/index.php/topic,6318.msg29483.html#msg29483
Meu ambiente é:
Hospedagem: UOL HOST, SC7, Mysql
Localhost: Vertrigo 2.29

O que eu verifiquei foi o seguinte:
- Defini tudo como UTF8: nos parâmetros do projeto, no form, no BD.
- No ambiente local a acentuação está correta.
- Fiz um dump do BD e importei na hospedagem do UOL.
- Olhando pelo PHPMYADMIN os acentos estão OK.
- Acessando o BD pelo form, os acentos vem todos "atravessados".
- Se eu alterar o registro e gravar, "estraga" no banco e no form fica OK.
- Se eu incluir um registro com acentuação (através do form gerado pelo SC), no banco fica "errado".
- Busquei os dados remotos com uma aplicação em VFP e os registros inclusos pelo formulário do SC em ambiente de produção vem "errado", os outros estão ok.
- Busquei os dados localmente com uma aplicação VFP e está td ok.

Isso tudo dá um "nó na cabeça"  hehehe

Pelo que conclui:
- Para o VFP é indiferente onde estão os dados, trazendo-os sempre da mesma forma.
- As rotinas usadas localmente pelos formulários do SC são diferentes das que são geradas para a publicação remotamente.

Toda ajuda para solucionar esse problema será bem vinda.