Autor Tópico: Pedido para correção de 2 problemas (Em vídeo)  (Lida 951 vezes)

rrma

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 816
  • Quem com porcos se mistura tanto bate até que fura
    • Email
Pedido para correção de 2 problemas (Em vídeo)
« Online: Novembro 13, 2012, 03:39:38 pm »
O primeiro vídeo mostra que botões tipo RUN usados em uma consulta, somem quando esta consulta é colocada como detalhe em um form mestre/detalhe. Executando a consulta individualmente o botão aparece e funciona normal.

http://www.youtube.com/watch?v=hm14K03tDOg

Este segundo vídeo mostra que o "tempo de refresh" setado numa consulta, funciona normalmente quando ela é executada individualmente, mas, ao usar esta mesma consulta como detalhe em um form mestre/detalhe, o tempo de refresh causa um bug na navegação do form pai, fazendo com que ele entre num loop infinito.

http://www.youtube.com/watch?v=MlRa-_l4HEM

Aumente a qualidade do vídeo ao executar no youtube.
Não postei na área de sugestões pois não se tratam de recursos novos a incorporar, e sim, de correções mesmo.
Rodrigo Araújo

Bernhard

  • Administrator
  • Expert
  • *****
  • Mensagens: 1619
Re:Pedido para correção de 2 problemas (Em vídeo)
« Responder #1 Online: Novembro 14, 2012, 01:14:36 am »
Boa noite rrma,

Em relação ao primeiro problema, os botões da aplicação não aparecem quando se trata de uma aplicação DETALHE. O Sr. pode enviar como sugestão que aplicações detalhe, continuem com seus botões através do nosso canal sugestao@netmake.com.br

Já no segundo, independente do tempo do refresh, o problema acontece? Se você definir 100s por exemplo, o problema acontece?

*Obs: Problema já reportado para nossa equipe de bugs.

att,
Bernhard Bernsmann

rrma

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 816
  • Quem com porcos se mistura tanto bate até que fura
    • Email
Re:Pedido para correção de 2 problemas (Em vídeo)
« Responder #2 Online: Novembro 14, 2012, 01:25:23 am »
Bernhard, o tempo de refresh tanto faz o valor, só não dá problema se deixar zerado.

Não entendo porque os botões não funcionam como detalhe, pois os detalhes rodam dentro de iframe. Não faz sentido nenhum.
Do jeito que está, se quisermos fazer um processamento tipo RUN em grid, temos que criar uma aplicação a parte. Outro detalhe é que os botões não funcionam apenas quando é grid. Quando é um form como detalhe, os botões criados funcionam.
Rodrigo Araújo

rrma

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 816
  • Quem com porcos se mistura tanto bate até que fura
    • Email
Re:Pedido para correção de 2 problemas (Em vídeo)
« Responder #3 Online: Dezembro 05, 2012, 04:51:22 pm »
Bernhard, o tempo de refresh tanto faz o valor, só não dá problema se deixar zerado.

Não entendo porque os botões não funcionam como detalhe, pois os detalhes rodam dentro de iframe. Não faz sentido nenhum.
Do jeito que está, se quisermos fazer um processamento tipo RUN em grid, temos que criar uma aplicação a parte. Outro detalhe é que os botões não funcionam apenas quando é grid. Quando é um form como detalhe, os botões criados funcionam.

Olá Bernhard,

Poderia dizer se o bug do refresh já foi corrigido?
Obrigado.
Rodrigo Araújo

Bernhard

  • Administrator
  • Expert
  • *****
  • Mensagens: 1619
Re:Pedido para correção de 2 problemas (Em vídeo)
« Responder #4 Online: Dezembro 06, 2012, 10:28:52 pm »
Boa noite Rodrigo,

Vou verificar o status do problema com nossa equipe de bugs.

att,
Bernhard Bernsmann

Yuri Esteves

  • Administrator
  • Expert
  • *****
  • Mensagens: 818
    • Email
Re:Pedido para correção de 2 problemas (Em vídeo)
« Responder #5 Online: Junho 09, 2016, 11:00:08 am »
A implementação desse caso, foi realizada na release 8.1.

Nas configurações da ligação Mestre detalhe para a consulta, existe a opção "Modo de visualização da Consulta", só marcar a opção "Habilitar todas as funcionalidades".

Agradecemos a sugestão para a melhoria da ferramenta.