Autor Tópico: [ RESOLVIDO ] Caracteres acentuados com problema  (Lida 1506 vezes)

Juliano

  • Intermediário
  • ***
  • Mensagens: 122
[ RESOLVIDO ] Caracteres acentuados com problema
« Online: Julho 13, 2012, 02:55:49 pm »
Boa Tarde pessoal,

Ao gerar um reportPDF se existem palavras acentuadas, o PDF não esta saindo corretamente.
E.: Melão (Base de dados) - > Melão (pdf criado).

Nos formulários e no banco de dados ele esta salvando normalmente e recuperando normalmente com acentuação,somente no reportPDF que não.

Alguma dica ?

Obrigado pela ajuda.
« Última modificação: Julho 16, 2012, 08:06:06 am por Juliano »

Juliano

  • Intermediário
  • ***
  • Mensagens: 122
Re:Caracteres acentuados com problema
« Responder #1 Online: Julho 16, 2012, 08:05:45 am »
Bom Dia Pessoal

Encontrei a solução para o problema:

basta usar
Código: [Selecionar]
{field1} = utf8_decode({field1}); para todos os campos que possam ter acentuação no seu reportPDF.

Obrigado.

fonte: http://www.scriptcase.net/forum_en_us/index.php?topic=3899.0

rayfcrols

  • Intermediário
  • ***
  • Mensagens: 193
Re:Caracteres acentuados com problema
« Responder #2 Online: Agosto 06, 2012, 10:06:11 am »
Como ? E em qual evento?????


Bom Dia Pessoal

Encontrei a solução para o problema:

basta usar
Código: [Selecionar]
{field1} = utf8_decode({field1}); para todos os campos que possam ter acentuação no seu reportPDF.

Obrigado.

fonte: http://www.scriptcase.net/forum_en_us/index.php?topic=3899.0

Juliano

  • Intermediário
  • ***
  • Mensagens: 122
Re:Caracteres acentuados com problema
« Responder #3 Online: Agosto 06, 2012, 05:06:22 pm »
Como ? E em qual evento?????


Bom Dia Pessoal

Encontrei a solução para o problema:

basta usar
Código: [Selecionar]
{field1} = utf8_decode({field1}); para todos os campos que possam ter acentuação no seu reportPDF.

Obrigado.

fonte: http://www.scriptcase.net/forum_en_us/index.php?topic=3899.0

Boa Tarde rayfcrols

Eu usei no onRecord, porém, ele só tem funcionando com campos nativos da consulta sql do pdfReport. Se você criar um campo na aplicação pdf e  fizer um select de outra tabela, ele não esta aplicando a função. A princípio, nenhuma função esta sendo aplicada quando se seleciona um campo de outra tabela dentro do pdfReport. Tentei usar a strtoupper() para deixar um campo maiúsculo e também se comportou dessa forma.