Autor Tópico: Problema para configurar banco postgres na produção (resolvido)  (Lida 1729 vezes)

ric_japa

  • Iniciante
  • **
  • Mensagens: 79
    • Email
Problema para configurar banco postgres na produção (resolvido)
« Online: Julho 11, 2012, 11:53:23 am »
Estou tentando publicar uma aplicação bem simples, criei uma grid, um menu e configurei o modulo de segurança por aplicativo, quando rodo pelo script case ele funciona normalmente.
Fiz a publicação como mostra no video fundamental 9, descompactei no meu servidor que é windows server 2003 rodando o apache com php.
Abri a aplicação e configurei o banco de dados, salvei e sai.
Entrei na aplicação novamente e tentei se logar ai aparece o erro.

ERROR
pg_query() [function.pg-query]: Query failed:
ERROR: schema "public" does not exist
Desculpe, mas o usuário não está ativo! Contacte o administrador!

« Última modificação: Julho 11, 2012, 02:54:39 pm por ric_japa »

ric_japa

  • Iniciante
  • **
  • Mensagens: 79
    • Email
Re:Problema para configurar banco postgres na produção
« Responder #1 Online: Julho 11, 2012, 02:54:19 pm »
Descobri o problema, eu acho que é um bug, o Scriptcase não aceita bancos pelo menos no postgres que não esteja no schema "public".
Se estiver em schema diferente ele da erro.
Se eu estiver errado por favor me informe.....

Obrigado....

Robert Berbert

  • Expert
  • *****
  • Mensagens: 769
  • Desenvolver é sempre estar se atualizando.
    • Conesoft
    • Email
Re:Problema para configurar banco postgres na produção (resolvido)
« Responder #2 Online: Julho 11, 2012, 03:01:47 pm »
O postgress tem essa chatice ai mesmo.
-- Design ou programador eis a questão.

Haroldo

  • Expert
  • *****
  • Mensagens: 6293
  • Conhecimento diminui limitações.△TFA△
    • Infinitus Web Gestão Empresarial/Gestão ITIL/Consultoria Scriptcase
Re:Problema para configurar banco postgres na produção (resolvido)
« Responder #3 Online: Julho 11, 2012, 05:34:24 pm »
na conexão em avançado vc pode configurar o schema, não?


ric_japa

  • Iniciante
  • **
  • Mensagens: 79
    • Email
Re:Problema para configurar banco postgres na produção (resolvido)
« Responder #4 Online: Setembro 13, 2012, 10:59:20 am »
na conexão em avançado vc pode configurar o schema, não?

Desculpe pela demora para responder, mas me parece que na conexão em avançado não da para escolher o schema, só possui a opção de não utilizar schema antes dos nomes das tabelas.

Eu gostaria muito de ter essa opção de escolher o schema na conexão. Pois tenho uma base que possui varios schemas com as mesmas tabelas ai precisaria poder na hora de publicar ou criar algum tipo de configuração para que o sistema pudesse configurar o schema.