Autor Tópico: Acionamento novo evento ajax em formulario  (Lida 2461 vezes)

brodao

  • Visitante
Acionamento novo evento ajax em formulario
« Online: Novembro 05, 2007, 10:31:02 pm »
Senhores,

Ao executar os passos abaixo, a CPU vai a 100% (consumidos pelo httpd) e após 8 min (não tive paciência para esperar) não obtenho nenhuma resposta no browser.

1. Iniciar novo formulario
2. Executar o wizard (next,next, finish)
3. Selecionar a nova aplicação
4. Selecionar (na arvore) "eventos ajax", "novo evento ajax", selecionar o campo e evento desejado

Grato,

PS: Versão baixada ontem do site (versão trial).

Haroldo

  • Expert
  • *****
  • Mensagens: 6274
  • Conhecimento diminui limitações.△TFA△
    • Infinitus Web Gestão Empresarial/Gestão ITIL/Consultoria Scriptcase
Re: Acionamento novo evento ajax em formulario
« Responder #1 Online: Novembro 06, 2007, 07:20:01 am »
Conforme a Netmake, esse problema vinha ocorrendo até a versão 149, que seria corrigido nas versões subsequentes.
Mas pelo que você esta verificando o problema ainda persiste.

Pedro Henrique

  • Novato
  • *
  • Mensagens: 22
    • IMIP
    • Email
Re: Acionamento novo evento ajax em formulario
« Responder #2 Online: Novembro 19, 2007, 12:23:22 pm »
O Sr. já foi no php.ini
e verificou se o memory_limit = 64M

é o minimo para rodar o scriptcase
Atenciosamnete
Pedro Henrique - Analista de Sistemas

brodao

  • Visitante
Re: Acionamento novo evento ajax em formulario
« Responder #3 Online: Novembro 21, 2007, 09:24:45 pm »
O problema não é de memória (esta com 64M sim).
É de processamento, pelo que parece esta entrando em "loop" em algum ponto.

netsoft

  • Visitante
Re: Acionamento novo evento ajax em formulario
« Responder #4 Online: Novembro 21, 2007, 11:01:24 pm »
se esta ok, verifique nos codigos que você construiu, porque pelo menos o meu roda normal.

Haroldo

  • Expert
  • *****
  • Mensagens: 6274
  • Conhecimento diminui limitações.△TFA△
    • Infinitus Web Gestão Empresarial/Gestão ITIL/Consultoria Scriptcase
Re: Acionamento novo evento ajax em formulario
« Responder #5 Online: Novembro 22, 2007, 01:02:06 pm »
ME PARECE QUE O APACHE 2.2 NO WINDOWS GERA ESSE PROBLEMA, TENTE COM O APACHE 1.3.

netsoft

  • Visitante
Re: Acionamento novo evento ajax em formulario
« Responder #6 Online: Novembro 22, 2007, 01:07:21 pm »
Se o scriptcase já tem um instalador, que faz tudo para você, qual o motivo da pessoa tentar rodar no windows, com outro apache ?

Apesar de versão superior, porque o apache 2.2 é melhor, e porque ele não roda no windows ?

brodao

  • Visitante
Re: Acionamento novo evento ajax em formulario
« Responder #7 Online: Novembro 22, 2007, 09:35:51 pm »
Ola Netsoft

Citar
se esta ok, verifique nos codigos que você construiu, porque pelo menos o meu roda normal.

Este é o problema, não consigo informar nenhum código. O "loop" ocorre ao acionar a opção de eventos ajax na arvore de navegação do SC.

Ola Haroldo,

Qto ao uso da versão 1.3 do apache, apesar de não concordar muito com isso, eu vou testar assim que tiver um tempo.

Grato aos colegas

Haroldo

  • Expert
  • *****
  • Mensagens: 6274
  • Conhecimento diminui limitações.△TFA△
    • Infinitus Web Gestão Empresarial/Gestão ITIL/Consultoria Scriptcase
Re: Acionamento novo evento ajax em formulario
« Responder #8 Online: Novembro 26, 2007, 02:14:30 pm »
Também não concordo com uso de versões anterior de produtos, se foram lançadas versões novas, são para corrigir problemas de segurança, bugs, além de obter melhorias...
A Instalação que a Netmake dispõe, causa um uso de CPU desnecessário, o que acarreta em performance baixa indesejável no equipamento, pois a mesma instala  o php em modo CGI (Perigosissímo para segurança).E outra a instalação é exclusiva para uso do Scriptcase, se você tem outros produtos e prcisa dosevidor para servir páginas alheias ao SC3, fica horrível, o resultado.
Geralmente eu uso o Xampp para instalação casada do Apache, PHP e MySql, funciona com tudo mesmo com o produto da NetMake no caso de criar um evento Ajax. Não sei sei quando isso será resolvido, mas por enquanto a solução é usar mesmo o instalador da NetMake, ou se algum usuário, cobra em apache, descobrir uma configuração ideal para o funcionamento do SC3, de modo que outros produtos rodem com satisfação também, e estiver disposto a compartilhar seus conhecimentos, será muito bem vindo.