Autor Tópico: Problema na Publicação - Formulário ficando indisponível - (*** RESOLVIDO ***)  (Lida 1515 vezes)

Adesoft

  • Avançado
  • ****
  • Mensagens: 355
    • Email
Caros amigos,

Estou um problema, ao publicar as aplicações em um cliente, tenho 3 aplicações, que mesmo sincronizando, e o usuário com direito total de acesso a estas aplicações, ela permanece indisponível, como se ele não tivesse direito de usar esta aplicação. Mais na guia de segurança ele esta com direito de uso. É como se o banco do SC que controla as aplicações não tivesse registrado esta aplicação.

Teria como reindexar as aplicações? Teria como fazer o SC (Produção no cliente) forçar a ler todas as aplicações com o módulo de segurança novamente?

Adeilson de Oliveira
« Última modificação: Maio 22, 2012, 09:38:12 am por Adesoft »
Adeilson de Oliveira
THS do Brasil

jovitomelo

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 916
    • Simples Assim
    • Email
Re:Problema na Publicação - Formulário ficando indisponível
« Responder #1 Online: Maio 03, 2012, 07:33:24 pm »
Existem duas tabelas a serem corrigidas: aplicações e grupos de aplicações.

Veja o registro que consta esta aplicação nas duas tabelas e apague os registros... a seguir atualize as permissões.

[]´s
Jovito Melo
Maceió - Alagoas

Adesoft

  • Avançado
  • ****
  • Mensagens: 355
    • Email
Re:Problema na Publicação - Formulário ficando indisponível
« Responder #2 Online: Maio 17, 2012, 04:57:31 pm »
Por garantia, fiz um Backup das tabelas e coloquei em outro micro, para a minha surpresa esta funcionando correto a segurança. Porém mesmo restaurando o backup o problema persiste.

São 3 aplicações que estão dando problemas, e são para os usuários que são Administradores, com acesso 100%.

Mesmo eu criando um novo usuário e dando 100% de acesso estas aplicações não ficam disponíveis.

Adeilson de Oliveira
Adeilson de Oliveira
THS do Brasil

Kleyber

  • Expert
  • *****
  • Mensagens: 2239
    • Email
Re:Problema na Publicação - Formulário ficando indisponível
« Responder #3 Online: Maio 17, 2012, 05:12:18 pm »
Adeilson boa tarde,

Deixa eu ver se entendi.
1 - O backup que vc fez vc colocou em outro computador e a aplicação de segurança funcionou normalmente nessa outra máquina? Funcionou a aplicação toda ou somente o módulo de segurança?

2 - Quando vc manda sincronizar, as aplicações novas ficam disponíveis para o sistema, mas não estão ainda ligadas a um grupo de usuários. Tem que entrar no grupo que vai ter acesso a essas aplicações e inserí-las no perfil. Chegaste a fazer isto?
Kleyber Derick

ITIL® V3 Foundation Certified
Analista de Sistemas
São Luís - Maranhão
www.tkinformidia.net

Adesoft

  • Avançado
  • ****
  • Mensagens: 355
    • Email
Re:Problema na Publicação - Formulário ficando indisponível
« Responder #4 Online: Maio 17, 2012, 10:10:54 pm »
Kleyber Derick,

Deixa eu ver se entendi.
1 - O backup que vc fez vc colocou em outro computador e a aplicação de segurança funcionou normalmente nessa outra máquina?
R: Sim, fiz um backup da base do cliente Mysql e restaurei o backup na minha máquina.

Funcionou a aplicação toda ou somente o módulo de segurança?
R: Toda a aplicação, todos os módulos, todos os formulários.

2 - Quando vc manda sincronizar, as aplicações novas ficam disponíveis para o sistema, mas não estão ainda ligadas a um grupo de usuários. Tem que entrar no grupo que vai ter acesso a essas aplicações e inserí-las no perfil. Chegaste a fazer isto?
R: Mesmo publicando todas as aplicações novamente e sincronizando, pego todas as aplicações e dou 100% de uso para o admin (Usuário adminsitrador), ao sair do sistema e entrar as mesmas 4 aplicações ainda ficam indisponivel, não tendo acesso.
Memso tentando criar um novo usuário dando 100% de acesso, estas aplicações no Cliente ainda permanece indisponivel.

Agradeço a ajuda.
Adeilson de Oliveira
Adeilson de Oliveira
THS do Brasil

Kleyber

  • Expert
  • *****
  • Mensagens: 2239
    • Email
Re:Problema na Publicação - Formulário ficando indisponível
« Responder #5 Online: Maio 18, 2012, 10:44:54 am »
Bom, o que posso deduzir é que há algo na máquina do cliente, a nível de configuração ou do SC ou do ambiente, pois se fosse um erro da aplicação ele teria que ter acontecido na tua máquina. Já tentaste desinstalar tudo da máquina do cliente e instalar a aplicação do zero, criando a conexão e tudo o mais?
Kleyber Derick

ITIL® V3 Foundation Certified
Analista de Sistemas
São Luís - Maranhão
www.tkinformidia.net

saulobborges

  • Expert
  • *****
  • Mensagens: 1392
    • SGi Sistemas
    • Email
Re:Problema na Publicação - Formulário ficando indisponível
« Responder #6 Online: Maio 18, 2012, 03:02:00 pm »
Limpa o cache..já sofri com algumas aplicações e a limpeza do cache e da pasta tmp do SC me livraram de alguns problemas.

Adesoft

  • Avançado
  • ****
  • Mensagens: 355
    • Email
Re:Problema na Publicação - Formulário ficando indisponível - *** Resolvido ***
« Responder #7 Online: Maio 22, 2012, 09:37:06 am »
 Agradeço a Ajuda de todos:

Para resolver o problema tive que segui vários procedimentos, não tive como reconstituir o problema para saber com precisão qual dos itens foram a solução, vou listar as tarefas que executei:

1) Limpeza de Cache
2) Exclui todos os registros da tabela Aplicações
3) Publiquei novamente todas as aplicações completa com imagens, ícones 100%
4) Exclui os índices das tabelas do Mysql ref. ao módulo de segurança
5) Recriei os índices

Após executar estes passos acima voltou a funcionar.

Muito Obrigado

Adeilson de Oliveira
Adeilson de Oliveira
THS do Brasil