Autor Tópico: Gostaria de saber o porquê disso!!!... “usar Título sim” não apare-se? no Select  (Lida 1940 vezes)

waldemargo_ol

  • Intermediário
  • ***
  • Mensagens: 115
Tenho visto que está ocorrendo um erro muito estranho que vários anos mexendo com a ferramenta SC nunca arrumarão este problema...

No modulo Lookup

Em usar Título sim

Quando você coloca para usar como sim você deverá adicionar o titulo para aparecer no select

Exemplo : <VAZIO> ou por exemplo titulo <TODOS>

Mas mesmo colocando como sim e pondo o título ele não apare-se

Gostaria de saber o porquê disso!!!... “usar Título sim” mesmo colocando não apare-se Lookup...

waae

  • Avançado
  • ****
  • Mensagens: 292
    • Email
estranho pq no meu está normal.

waldemargo_ol

  • Intermediário
  • ***
  • Mensagens: 115
Qual sistema operacional você está usando

No meu caso foi estalado o SC 6 no Windows SP3

Não sei se tem alguma coisa aver somente o erro no windows

Mas nunca resolve este problema

waae

  • Avançado
  • ****
  • Mensagens: 292
    • Email
Olha, fiz um teste aqui que não pensei na primeira resposta... vc tá usando isso no título "<" e ">" ???
Pq eu coloquei e ai passou a não funcionar!!!

Eu uso somente:
selecione...
e funciona.

Quando coloquei:
<selecione...>
não funcionou mesmo!

jovitomelo

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 916
    • Simples Assim
    • Email
Pessoal,

Eu coloco ---Informe--- e tá tudo ok.

Mas existe uma situação que ele não aparecia de jeito nenhum (nem rezando pro meu padin pade ciço rumão batista) se fosse colocado em uma app DETALHE... mas corrigiram na V6.0.008 (testei agora)

Testem e retornem.
« Última modificação: Março 28, 2012, 12:08:52 pm por jovitomelo »
Jovito Melo
Maceió - Alagoas

waldemargo_ol

  • Intermediário
  • ***
  • Mensagens: 115
Realmente se colocar "<>" ele não funciona

Não sei por que é muito estranho isso

Vou testar de outra maneira como vocês falaram

waae

  • Avançado
  • ****
  • Mensagens: 292
    • Email
Acho que esse caracter anula o conteudo de dentro pq é 'lido' como comando html... igual a <b> <i> <a href> ....
O mesmo acontece se você colocar "[selecione]", ele considera o "selecione" uma variável global.

jovitomelo

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 916
    • Simples Assim
    • Email
Ele entende como uma tag.
Jovito Melo
Maceió - Alagoas

rrma

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 816
  • Quem com porcos se mistura tanto bate até que fura
    • Email
Eu costumo marcar como sim, deixar o conteúdo em branco e usar o valor 0 pra poder validar, assim os selects iniciam em branco e não corro o risco do usuário deixar como aparece inicialmente.
Rodrigo Araújo

waae

  • Avançado
  • ****
  • Mensagens: 292
    • Email
Ele entende como uma tag.

Isso TAG.... fugiu a palavra!

George Carvalho

  • Expert
  • *****
  • Mensagens: 1371
    • Email
Assim funciona: >>Selecione<<
George Carvalho
Porto de Galinhas/PE