Autor Tópico: BUG ou BANCO DE DADOS??  (Lida 1676 vezes)

unijet2

  • Visitante
BUG ou BANCO DE DADOS??
« Online: Agosto 14, 2007, 11:02:58 am »
Olá, é o seguinte:

Estava criando consultas com a opção de selecionar o número de linhas. Ok, funcionava uma maravilha, porém depois de um certo tempo, da noite pro dia, simplesmente parou de funcionar, e então ativei o modo debug e identifiquei que quando eu atualizo o número de páginas, a aplicação não está mais realizando a query "select" com  o "limit x,x " atualizado com o valor informado no campo que recebe esse valor!

Alguém sabe o que poderia ser?? alguma configuração da consulta?? banco de dados com alguma configuração??? ou simplesmente um bug do scriptcase?

Utilizo como banco de dados um cliente MySQL 5.0.22, rodando num servidor linux, e para publicação utilizo um data center que me oferece um cliente MySQL 4.1.22, também rodando em linux.


AH, quase me esqueço, também não consigo mais abrir filtros pela consulta, quando eu clico no filtro ele simplesmente carrega o grid novamente, da mesma maneira que ocorre quando eu tento modificar o número de linhas! O mesmo problema ocorre com a criação de XLS, CSV, e também ao clicar na lupa de detalhe do registro! que coisa não?

Se alguém souber de algo, agradeço desde já!
« Última modificação: Agosto 14, 2007, 11:18:10 am por unijet2 »

Haroldo

  • Expert
  • *****
  • Mensagens: 6277
  • Conhecimento diminui limitações.△TFA△
    • Infinitus Web Gestão Empresarial/Gestão ITIL/Consultoria Scriptcase
Re: BUG ou BANCO DE DADOS??
« Responder #1 Online: Agosto 15, 2007, 09:53:10 am »
atualize os arquivos de produção e regere todos os fontes e publique tudo novamente...
Em sua maquina de desenvolvimento como esta?

unijet2

  • Visitante
Re: BUG ou BANCO DE DADOS??
« Responder #2 Online: Agosto 15, 2007, 10:29:10 am »
Bom, valeu pela dica, vou tentar fazer isso, espero que funcione...

Mas acontece que, por exemplo, hoje de manhã eu cheguei, liguei minha máquina, modifiquei uma consulta, adicionando uma botao de impressao html, compilei e funcionou normal, ai publiquei em arquivo zip, mandei pro host, e la não funcionou mais, voltei e compilei de novo o arquivo no scriptcase e pimba, não rodou novamente!! e agora sei lá quando que vai funcionar de novo!!

E também, eu rodando o ambiente de produção no meu windows XP, na máquina que eu uso pra acessar o scriptcase, que ta no servidor linux, e com um MySQL 5.0.33, funciona uma beleza!!! chega dar vontade de chorar de tanta emoção(hehehehehe)!

Bom, mãos à obra, senão to vendo que to gerar relatórios no braço mesmo com o php!!!

unijet2

  • Visitante
Re: BUG ou BANCO DE DADOS??
« Responder #3 Online: Agosto 16, 2007, 04:52:26 pm »
vixi maria, funcionou nada aqui não!!! depois de uma atualização que teve ontem no scriptcase, até funcionou, mas foi soh eu publicar pra dar pau!! será que poder alguma coisa que ocorre com a publicação???? pq eu publico e não funciona a barra de ferramentas da consulta lá no host!! daí eu volto pra ver como que ta na máquina de desenvolvimento, e por mágica para de funcionar!!!raios!!!


bom, e lá vamos nós de novo!!

fui!

unijet2

  • Visitante
Re: BUG ou BANCO DE DADOS??
« Responder #4 Online: Setembro 24, 2007, 11:21:42 am »
Pessoal

Depois de anos e anos, resolvi meu problema!!! Não sei se costumam ver esses posts antigos, mas eu vou deixar aqui a resolução do meu problema caso alguém tenha caso semelhante!

O que acontecia é que eu tinha um MENU principal que possuia como itens, OUTROS MENUS que abriam de forma vcertical EMBAIXO e na MESMA JANELA do menu principal, e logo no centro da MESMA JANELA, abria-se as aplicações, fazendo com que não funcionasse de jeito maneira a barra de ferramentas das consultas...

como eu descobri que isso era o problema???certo dia resolvi tirar aquele menu principal para fazer uns debugs, e pimba, as consulta funcionaram tranquilo!!!

Logo, tive que fazer os outros menus abrirem como uma nova janela, fechando o menu principal!!!

seria isso um bug???? ou é assim mesmo que funciona???

Abraços, até a próxima!!