Autor Tópico: Versão 6 - Seguraça  (Lida 867 vezes)

Herberto Silva

  • Avançado
  • ****
  • Mensagens: 334
  • Programador Freelancer
    • Desenvolvimento de Software
    • Email
Versão 6 - Seguraça
« Online: Março 13, 2012, 09:14:34 pm »
Uma dúvida: Consegui instalar uma aplicação desenvolvida na V6 num servidor remoto que tem Versão do PHP ,5.2.9.
Pelo que estive a testar da a entender que a maior parte das opções de acesso, menu form e grid funcionam.
Tenho é um problema na definição das aplicações por grupo na area da segurança, a Secção que acedo para indicar quais as aplicações que o grupo (Gestores) tem acesso aparecem repetidas.
por exemplo aparece :
Actualização - Grupos / Aplicações           Group: Gestores           14/03/2012       
1       
     Selecionar   App Name *    Priv Access   Priv Insert   Priv Delete   Priv Update   Priv Export   Priv Print
1          form_empresaYesesYesYesYesYes          
2          form_empresaYesesYesYesYesYes          
3          form_empresaYesesYesYesYesYes          

Quando selecciono algum deles e gravo a aplicação indica-me o erro:
ERROR    
Erros linha(s)2: Erro ao alterar a base de dados - Registo inexistente
mas existe a aplicação na tabela de aplicações.
Será problema do Versão do PHP    5.2.9?
Alguém ja aconteceu semelhante coisa?
Alguma sugestão?
Obrigada
Cumprimentos,
Herberto Silva
herberto.silva@sapo.pt
skype: herbertobfsilva
www.software-global.info

John L. Santos

  • Bug Tracker Team
  • Administrator
  • Expert
  • *****
  • Mensagens: 595
    • Email
Re:Versão 6 - Seguraça
« Responder #1 Online: Março 14, 2012, 09:58:29 am »
Eu sugiro que você republique o projeto de maneira típica(http://downloads.scriptcase.com.br/downloads/v6/manual/pt_br/webhelp/manual_mp/30-Publicando_Aplicacoes/01-tipica.html), limpando a pasta tmp e certificando-se de que todas as permissões tenham sido dadas. Caso o problema persista, verifique a versão do PHP.

Os requisitos são os seguintes:

 -  Servidor Web com suporte ao PHP, tais como: Apache, IIS
 -  PHP 5.3, com os módulos mbstring, zip e gd2 habilitados
 -  Zend Guard Loader
 -  Banco de dados padrão SQL (SQLite, MySQL, MSSQL, PostgreSQL, Oracle e DB2) acessível ao PHP
John L. Santos
NetMake - Soluções em Informática