Autor Tópico: Bug. V.5.2.40 - Ligação de Campos do Tipo Imagem HTML  (Lida 848 vezes)

Adesoft

  • Avançado
  • ****
  • Mensagens: 355
    • Email
Bug. V.5.2.40 - Ligação de Campos do Tipo Imagem HTML
« Online: Outubro 31, 2011, 11:15:07 am »
Caros amigos,
Gostaria de publicar um bug, que percebi ao realizar uma ligação de um campo Imagem HTML chamando um novo grid.
Simulação do Bug:
Usando Mestre / Detalhe

1) Crie um formulário (Tipo Grid Evitável) para ser usado como detalhe de um Mestre, pegando um campo da sua tabela  do tipo texto formato HTML (Editor HTML)
2) Crie um outro formulário (Tipo Grid Evitável) para ser usado como detalhe de um Mestre, pegando alguns campos, exemplo itens de pedido.
3) Crie o formulário Mestre chamando o detalhe (Grid Evitável  nro. 2 do exemplo citado acima).

- No detalhe (exemplo nro 2.) crie um campo do tipo Imagem THML, e associe uma imagem a este campo, e na própria edição do campo coloque uma imagem associada.
- Ele vai habilitar logo abaixo um botão de ligação (Aqui começa o Bug).
- Você vai usar o botão de ligação que esta dentro da edição do campo abaixo do local e nome da imagem para fazer a ligação com o formulário detalhe nro. 01 (conforme citado acima).
- Após ter feito a ligação vá até o menu do formulário, parte ligação e verá que a ligação foi criada com sucesso.

Porém: (Bug)
Para simular o problema edite novamente o campo do formulário detalhe nro. 02 (citado acima) onde temos a imagem que esta com uma ligação para o formulário nro. 01 (citado acima) ao editar a ligação ele não traz como default o formulário escolhido da ligação que neste caso é o nro. 01, você precisa selecionar novamente, e após salvar a edição o SC, gera uma nova ligação no menu principal opção ligação. E para cada edição do campo de ligação ele vai gerar uma nova ligação, se você editar 3 vezes ele vai gerar automaticamente 3 ligações para o mesmo campo.
At.

Adeilson de Oliveira
Adeilson de Oliveira
THS do Brasil