Autor Tópico: Problemas na Conversão do Scriptcase 5  (Lida 1888 vezes)

Flávio Henrique

  • Novato
  • *
  • Mensagens: 25
    • FHSYS Soluções em TI
Problemas na Conversão do Scriptcase 5
« Online: Julho 14, 2011, 02:57:03 pm »
Olá pessoal,
sou novato no fórum, mas tenho grande experiência na utilização do Scriptcase(usamos desde a versão 2) e, sempre que existem atualizações de versões, motivo na qual deixamos de atualizar nossa ferramenta desde a versão 4.26(que é a que estamos utilizando até hoje).
Tentei por infinitas vezes atualizar nossa versão, mas como já temos GRANDE EXPERIÊNCIA em nos prejudicarmos atualizando por cima da versão atual, sempre que sai uma release(ou versão) nova, temos o trabalho de criar um novo banco, uma nova pasta, e ir migrando projeto por projeto, validando todas as suas funções, coisa q sempre é desagradável, considerando que o intuito de atualização é melhorar e otimizar a ferramenta em prol do cliente. Coisa que NUNCA aconteceu.

Quando saiu a versão 5, eu baixei a primeira release e fiz a instalação do zero, configurei tudo e fiz a conversão, não obtive avisos de erros ou qualquer outro problema, mas tivemos problemas na publicação do cliente, o layout ficou completamente perdido logo no primeiro projeto(sempre escolhemos o menor para testar). Após esse problema, ignoramos completamente essa versão, pois vimos que seria um retrabalho essa atualização.

Após vários meses e releases, fui tentado a tentar migrar novamente, mas agora para a versão 5.1.018, e identificamos o problema na migração dos tema(schema), pois nós possuimos nosso próprio e no momento da impressão ele simplesmente ignorava esse tema. Entrei em contato com o suporte e fui informado que isso seria revisto para o próximo release. Mais uma vez ignoramos a atualização e ficamos na versão 4.26.

Mais alguns meses depois, verifiquei que a ferramenta havia evoluído para a versão 5.2.015, tentei novamente a migração, mas o grande problema continuava. O Scriptcase não conseguia importar o tema da versão 4 para o 5. Nem preciso dizer q voltamos para a 4.26 né(rs).

Atualmente, resolvi tentar minha última atualização com a versão 5.2.019, criei uma pasta versao-5, e criei um banco no mysql para essa conexão também(aqui utilizamos um banco externo para gravar as informações do projeto).
Ao tentar utilizar o conversor do projeto, após informar a pasta onde a versão 4 fica ele me apresenta o seguinte erro:

Citar
Warning: main(/prod/third/ezxml/ezxml.php) [function.main]: failed to open stream: No such file or directory in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 40

Warning: main() [function.include]: Failed opening '/prod/third/ezxml/ezxml.php' for inclusion (include_path='.;C:\php5\pear') in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 40

Warning: main(/prod/third/ezxml/ezdomnode.php) [function.main]: failed to open stream: No such file or directory in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 41

Warning: main() [function.include]: Failed opening '/prod/third/ezxml/ezdomnode.php' for inclusion (include_path='.;C:\php5\pear') in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 41

Warning: main(/prod/third/ezxml/ezdomdocument.php) [function.main]: failed to open stream: No such file or directory in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 42

Warning: main() [function.include]: Failed opening '/prod/third/ezxml/ezdomdocument.php' for inclusion (include_path='.;C:\php5\pear') in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 42

Warning: main(/prod/third/adodb/adodb.inc.php) [function.main]: failed to open stream: No such file or directory in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 43

Warning: main() [function.include]: Failed opening '/prod/third/adodb/adodb.inc.php' for inclusion (include_path='.;C:\php5\pear') in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 43

Warning: main(/prod/lib/php/nm_ini_lib.php) [function.main]: failed to open stream: No such file or directory in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 44

Warning: main() [function.include]: Failed opening '/prod/lib/php/nm_ini_lib.php' for inclusion (include_path='.;C:\php5\pear') in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 44

Fatal error: Call to undefined function decode_string() in C:\ServidorWeb\clientes\Microcis\websites\scriptcase.desenv.mcs\versao-5\devel\conversor_v5\conv_arqs.php on line 222

Alguém também sofreu esse problema?

Flávio Henrique
Analista de Sistemas
Niterói/RJ
www.fhsys.com.br

Flávio Henrique

  • Novato
  • *
  • Mensagens: 25
    • FHSYS Soluções em TI
Re:Problemas na Conversão do Scriptcase 5
« Responder #1 Online: Fevereiro 09, 2012, 09:22:50 am »
Ninguém? Depois de 6 meses de post será q eu sou o único a ter esse problema???
Flávio Henrique
Analista de Sistemas
Niterói/RJ
www.fhsys.com.br

geoimob

  • Novato
  • *
  • Mensagens: 38
Re:Problemas na Conversão do Scriptcase 5
« Responder #2 Online: Novembro 22, 2012, 09:25:55 am »
Nao posso ajuda mas posso dizer que estou com problemas para migrar o sistema da vesao 5 pra 6. Estou tentando finalizar um projeto ja a muito tempo e infelizmente sempre tenho tido problemas; tenho trabalhado com otimos profissionais. Especilistas no sistema mas ainda sem sucesso.

Bernhard

  • Administrator
  • Expert
  • *****
  • Mensagens: 1619
Re:Problemas na Conversão do Scriptcase 5
« Responder #3 Online: Novembro 26, 2012, 09:29:26 pm »
Boa noite,

Por gentileza entre em contato com nosso suporte para um maior auxílio na migração de sistemas da V5 para V6.

att,
Bernhard Bernsmann