Autor Tópico: BUG: Validar com Máscara não funciona  (Lida 1240 vezes)

Higor Vaz

  • Iniciante
  • **
  • Mensagens: 95
  • Eeeeu
    • Email
BUG: Validar com Máscara não funciona
« Online: Março 30, 2011, 11:40:30 pm »
Alguem já teve a curisidade de testar:
Validar com máscara num form Único Registro, a máscara formata, mostra o erro e mesmo assim o dado é salvo.
Se alguem puder testar e postar os resultados eu agradeço.
Compartilhe o conhecimento que Deus lhe dá e receberá mais.
Higor Vaz

Higor Vaz

  • Iniciante
  • **
  • Mensagens: 95
  • Eeeeu
    • Email
Re: BUG: Validar com Máscara não funciona
« Responder #1 Online: Março 31, 2011, 11:31:57 am »
Realmente é um bug e o suporte disse que hoje ou amanha sai a correção: 5.2.0010
Para quem não entendeu ainda:
Qualquer valor que siga o padrão ele aceita e formata e mesmo assim o dado imcompleto/errado é salvo no banco.
Ex:
///TODOS ESTES VALORES ESTÃO SENDO POSSÍVEIS DE SALVAR NO BANCO
AA
AAA
AAA - 1
AAA - 12
AAA - 123
///TODOS ESTES VALORES ESTÃO SENDO POSSÍVEIS DE SALVAR NO BANCO

///SENDO QUE SOMENTE PODERIA SER SALVO O FORMATO COMPLETO
AAA - 1234
///SENDO QUE SOMENTE PODERIA SER SALVO O FORMATO COMPLETO
Compartilhe o conhecimento que Deus lhe dá e receberá mais.
Higor Vaz

Max Veras

  • Administrator
  • Intermediário
  • *****
  • Mensagens: 203
Re: BUG: Validar com Máscara não funciona
« Responder #2 Online: Abril 04, 2011, 10:50:44 am »
Higor, já foi lançado a nova versão com essa correção.

nelson machado

  • Novato
  • *
  • Mensagens: 11
    • Email
Re:BUG: Validar com Máscara não funciona
« Responder #3 Online: Julho 11, 2011, 04:23:20 pm »
validação de campos com firebird 1.5 ou 2.0  não funciona.
(##) ####-#### tem problema na hora de gravar
versao 5.02.0029