Autor Tópico: SCRIPTCASE V5.0.10 NO UBUNTU 10.04  (Lida 5445 vezes)

Jailton

  • Expert
  • *****
  • Mensagens: 2031
SCRIPTCASE V5.0.10 NO UBUNTU 10.04
« Online: Maio 01, 2010, 12:37:03 am »
Pessoal, alguém já instalou? o SCRIPTCASE no UBUNTU 10.04 LTS 64,

eu instalei aqui foi tudo normal só o ZEND OPTMIZER 3.3.9 que na hora de executar o SCRIPTCASE ele não reconhece, mas usando o phpinfo(); ele mostra como habilitado.

Fiz a instalação seguindo as linhas abaixo:
INSTALANDO O ZENDO OPTMIZER

$ sudo gedit /etc/php5/apache2/php.ini
No fim do arquivo adicione essas 3 linhas:
[Zend]
zend_extension=/usr/local/lib/Zend/ZendOptimizer.so
zend_optimizer.optimization_level = 15


$ sudo mkdir /usr/local/lib/Zend
$ tar zxpvf ZendOptimizer-3.3.9-linux-glibc23-x86_64.tar.gz

$ cd ZendOptimizer-3.3.9-linux-glibc23-x86_64/data

** Ver qual a versão do PHP e olha na pasta /data/ qual a versão compátivel;
   para ver a versão do php: http://localhost/versao_php.php

$ cd 5_2_x_comp    (Versão compativel com PHP 5.2.x e 5.3.x)

$ sudo cp ZendOptimizer.so /usr/local/lib/Zend

$ sudo /etc/init.d/apache2 restart

** Pronto Zend Optimizer instalado.

E usando o http://localhost/versao_php.php acusa que esta enable, ZEND ENGINE 2, etc.

« Última modificação: Maio 01, 2010, 12:39:17 am por Jailton »
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.

Jailton

  • Expert
  • *****
  • Mensagens: 2031
Re: SCRIPTCASE V5.0.10 NO UBUNTU 10.04
« Responder #1 Online: Maio 01, 2010, 12:23:51 pm »
BOM resolvi fazendo o DownGrade da versão 5.3 do Lucid para a 5.2 do Karmic

** O ZEND OPTMIZER ATÉ ABRIL/2010 SÓ é compativel ATÉ O PHP 5.2
   E UBUNTU 10.04 JÁ VEM COM O PHP 5.3 então a gente tem que instalar
   a versão 5.2 na unha antes de prosseguir a instalação do PHP:
* Duplicar e Redirecionar repositórios do PHP ANTIGO:
No Terminal:
$ sed s/lucid/karmic/g /etc/apt/sources.list | sudo tee /etc/apt/sources.list.d/karmic.list
$ sudo su
# cd /etc/apt/preferences.d
bom aqui temos que criar 7 arquivos, com os módulos que vamos pegar da versão 5.2:

$ gedit php5       (Colar o Texto abaixo e gravar)
Package: php5
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-common       (Colar o Texto abaixo e gravar)
Package: php5-common
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-gd       (Colar o Texto abaixo e gravar)
Package: php5-gd
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-interbase       (Esse é opcional é que eu uso Firebird Também)
Package: php5-interbase
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-mcrypt       (Colar o Texto abaixo e gravar)
Package: php5-mcrypt
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-mysql       (Colar o Texto abaixo e gravar)
Package: php5-mysql
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-sqlite       (Colar o Texto abaixo e gravar)
Package: php5-sqlite
Pin: release a=karmic
Pin-Priority: 991


** Bom esses são os modulos do php5 que uso caso usarem outros é só seguir esse esquema.

$ sudo apt-get update   (para atualizar os repositórios novos).

** Pronto agora seguir a instalação normalmente, como no tutorial da NETMAKE.
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.

Control Easy

  • Novato
  • *
  • Mensagens: 8
  • Control Easy Tecnologia
    • Control Easy Tecnologia
    • Email
Re: SCRIPTCASE V5.0.10 NO UBUNTU 10.04
« Responder #2 Online: Janeiro 27, 2011, 05:34:43 pm »
Boa tarde.

Alguém sabe se o Zend Optimizer já é compatível com o PHP 5.3?

Obrigado
Control Easy Tecnologia
www.controleasy.com.br
15 3411-7520

CRFont

  • Visitante
Re: SCRIPTCASE V5.0.10 NO UBUNTU 10.04
« Responder #3 Online: Janeiro 27, 2011, 05:45:00 pm »
Boa noite Evandro.

Ainda não é compatível.

Control Easy

  • Novato
  • *
  • Mensagens: 8
  • Control Easy Tecnologia
    • Control Easy Tecnologia
    • Email
Re: SCRIPTCASE V5.0.10 NO UBUNTU 10.04
« Responder #4 Online: Janeiro 28, 2011, 09:20:45 am »
Obrigado Rafael.

Aproveitando este tópico, hoje estou usando para meu ambiente de desenvolvimento o Ubuntu 9.10 desktop num Intel Core 2 duo E7500 com 4Gb de memória, terei ganho de performance se mudar para o Ubuntu 10.04 LTS desktop num Intel Core i5-650 com 4Gb de memória?

Usar 64bits melhora a performance geral?

O fato de ser necessário o down grade do PHP para 5.2 diminui a performance ou trás algum problema?

Desde já obrigado!
Control Easy Tecnologia
www.controleasy.com.br
15 3411-7520

possebon_RR

  • Novato
  • *
  • Mensagens: 1
    • Email
Re: SCRIPTCASE V5.0.10 NO UBUNTU 10.04
« Responder #5 Online: Fevereiro 10, 2011, 09:38:01 pm »
BOM resolvi fazendo o DownGrade da versão 5.3 do Lucid para a 5.2 do Karmic

** O ZEND OPTMIZER ATÉ ABRIL/2010 SÓ é compativel ATÉ O PHP 5.2
   E UBUNTU 10.04 JÁ VEM COM O PHP 5.3 então a gente tem que instalar
   a versão 5.2 na unha antes de prosseguir a instalação do PHP:
* Duplicar e Redirecionar repositórios do PHP ANTIGO:
No Terminal:
$ sed s/lucid/karmic/g /etc/apt/sources.list | sudo tee /etc/apt/sources.list.d/karmic.list
$ sudo su
# cd /etc/apt/preferences.d
bom aqui temos que criar 7 arquivos, com os módulos que vamos pegar da versão 5.2:

$ gedit php5       (Colar o Texto abaixo e gravar)
Package: php5
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-common       (Colar o Texto abaixo e gravar)
Package: php5-common
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-gd       (Colar o Texto abaixo e gravar)
Package: php5-gd
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-interbase       (Esse é opcional é que eu uso Firebird Também)
Package: php5-interbase
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-mcrypt       (Colar o Texto abaixo e gravar)
Package: php5-mcrypt
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-mysql       (Colar o Texto abaixo e gravar)
Package: php5-mysql
Pin: release a=karmic
Pin-Priority: 991

$ gedit php5-sqlite       (Colar o Texto abaixo e gravar)
Package: php5-sqlite
Pin: release a=karmic
Pin-Priority: 991








PARTICULARMENTE EU TIVE MAIOR SUCESO COM ESTE MODELO....
DE QUALQUER FORMA.... MUITO OBRIGADO Jailton
Att,

    * Alexandre Possebon
    * Graduado em Administração com Habilitação em Sistemas de Informação
    * Pós Graduando em Engenharia de Sistemas
    * Especializado em Desenvolvimento PHP/MySQL - WEB 2.0
    * Plataforma Linux

Erikson Flávio

  • Iniciante
  • **
  • Mensagens: 71
    • Email
Re:SCRIPTCASE V5.0.10 NO UBUNTU 10.04
« Responder #6 Online: Fevereiro 01, 2013, 11:56:06 pm »
Caro colegas,

Para o PHP 5.3 deve ser utilizado o Zend Guard Loader ao invés do Zend Optimizer, segundo a própia Zend. Fiz a instalação assim e funcionou perfeito. Veja tutorial no tópico http://www.netmake.com.br/forum/index.php/topic,6221.0.html

Abraço a todos!
Desenvolvedor PHP/Java/Oracle/MySQL - Veterano
ScriptCase - Intermediário