Atualize hoje para o Scriptcase 9 e ganhe 35% de desconto! Atualize hoje para o Scriptcase 9 e ganhe 35% de desconto! COMPRAR AGORA!

Autor Tópico: [RESOLVIDO] Conversão V8 V9 - Parse error: syntax error, unexpected ''  (Lida 173 vezes)

William

  • Novato
  • *
  • Mensagens: 6
Boa tarde Pessoal,

Após converter um projeto V8 para V9 esta ocorrendo um erro uma aplicação de grid

Parse error: syntax error, unexpected '' (T_ENCAPSED_AND_WHITESPACE), expecting identifier (T_STRING) or variable (T_VARIABLE) or number (T_NUM_STRING) in /opt/NetMake/v9/wwwroot/scriptcase/app/AquaControl/grid_RD_Logs/grid_RD_Logs_grid.class.php on line 1813

Alguem tem alguma ideia do que pode ser?

No V8 continua funcionando perfeitamente.

Obrigado
« Última modificação: Junho 27, 2017, 05:54:22 pm por Yuri Esteves »

William

  • Novato
  • *
  • Mensagens: 6
[RESOLVIDO] Re:Conversão V8 V9 - Parse error: syntax error, unexpected ''
« Responder #1 Online: Maio 12, 2017, 05:56:28 pm »
No SC8 usava o no Label do Campo uma variável global, no SC9 gera o erro apresentado acima.
Vou procurar outra forma de modificar o Label dinamicamente.

Moacir de Oliveira

  • Iniciante
  • **
  • Mensagens: 88
    • Email
Re:[RESOLVIDO] Conversão V8 V9 - Parse error: syntax error, unexpected ''
« Responder #2 Online: Maio 12, 2017, 06:38:11 pm »
Ola


Acho que tem que debugar e analisar o codigo fonte para detectar a causa.
No win 10 tive varios problemas com as Grids da V8 e resolvi todas dessa maneira.
Por exemplo tive uma grid que ele converteu um campo datetime do sqlserver e colocou na sql da consulta como "data" com as aspas e na execução dava erro.
« Última modificação: Maio 12, 2017, 06:40:32 pm por Moacir de Oliveira »
Atenciosamente

Moacir de Oliveira
São Paulo - SP

Yuri Esteves

  • Administrator
  • Expert
  • *****
  • Mensagens: 878
    • Email
Re:[RESOLVIDO] Conversão V8 V9 - Parse error: syntax error, unexpected ''
« Responder #3 Online: Junho 27, 2017, 05:54:14 pm »
O problema foi corrigido na release v9.0.004 do Scriptcase.

Mantenha a sua versão sempre com a ultima versão.