Final de ano com 25 % OFF para compra e renovaÇÃo!

Autor Tópico: Imagem Não Aparece no Formulário  (Lida 413 vezes)

inosys

  • Intermediário
  • ***
  • Mensagens: 217
  • Só o Senhor é Deus!
    • Email
Imagem Não Aparece no Formulário
« Online: Março 29, 2017, 07:27:46 pm »
Amigos,
Olá !

Tenho um cadastro de Funcionários e nesse cadastro tenho a foto do mesmo. Quero padronizar o tamanho da foto. Para isso posso usar a altura e a largura da imagem.
Quando não coloco altura (0) e nem coloco largura(0), deixando zerado, a imagem aparece no formulario.

Se eu configurar Altura e Largura, a imagem não aparece mais, fica o quadrado da imagem com um X Vermelho.

Que coisa não?

É um campo do tipo Imagem (Caminho do Arquivo), onde a foto fica no servidor.

Sem configurar altura e largura da certo, mais preciso configurar, ou então terei que redimensionar 12 mil fotos kkk

SC 8.1 última release. Alguém pode testar ai e me ajudar?

Abração !
Atenciosamente
Watson Passos

inosys

  • Intermediário
  • ***
  • Mensagens: 217
  • Só o Senhor é Deus!
    • Email
Re:Imagem Não Aparece no Formulário
« Responder #1 Online: Março 30, 2017, 08:55:01 am »
Bom dia Amigos,

Percebi ao ver o fonte (*.php) publicado que a imagem fica com o seguinte padrão de nome de arquivo:
Sem especificar altura e largura: [nome_temporário].[extensão] ==> não ocorre erro
Especificando altura e largura: [altura][largura][nome_temporário].[extensão] ==> ocorre erro

na pasta tmp do servidor tanto uma situação quanto a outra é gerado [nome_temporário].[extensão], por isso o erro ao especificar altura e largura.

Ou Seja, se eu especificar a altura e a largura, esses dados estão compondo o nome do arquivo temporário fazendo com que não seja localizado.

Existe alguma configuração ou é BUG mesmo Netmake?
Atenciosamente
Watson Passos

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 1978
  • Focalize as oportunidades e não os obstáculos.
    • Simão & Bühler Ltda
    • Email
Re:Imagem Não Aparece no Formulário
« Responder #2 Online: Março 30, 2017, 10:44:31 am »
inosys,
Não tenho conhecimento se isto é um bug.
Relate no bugs@netmake.com.br e feedback@netmake.com.br
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada. Temos servidores dedicados.
Eu RTFM todo dia e você?

inosys

  • Intermediário
  • ***
  • Mensagens: 217
  • Só o Senhor é Deus!
    • Email
Re:Imagem Não Aparece no Formulário
« Responder #3 Online: Março 30, 2017, 09:19:57 pm »
mandei ontem um e-mail para o bugs mas ainda não recebi retorno.
Possivelmente é sim.
Atenciosamente
Watson Passos

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 1978
  • Focalize as oportunidades e não os obstáculos.
    • Simão & Bühler Ltda
    • Email
Re:Imagem Não Aparece no Formulário
« Responder #4 Online: Março 31, 2017, 08:20:02 am »
mandei ontem um e-mail para o bugs mas ainda não recebi retorno.
Possivelmente é sim.

Eles demoram um pouco para responder. Mas sempre me deram uma resposta.
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada. Temos servidores dedicados.
Eu RTFM todo dia e você?

Willian Formagio

  • Novato
  • *
  • Mensagens: 14
    • Email
Re:Imagem Não Aparece no Formulário
« Responder #5 Online: Abril 18, 2017, 03:11:35 pm »
inosys,

Você obteve retorno? Pois estou com o mesmo problema.

joeltonsilva

  • Expert
  • *****
  • Mensagens: 695
Re:Imagem Não Aparece no Formulário
« Responder #6 Online: Abril 19, 2017, 09:56:52 am »
Mesma situação...

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 1978
  • Focalize as oportunidades e não os obstáculos.
    • Simão & Bühler Ltda
    • Email
Re:Imagem Não Aparece no Formulário
« Responder #7 Online: Abril 19, 2017, 11:07:43 am »
É importante que todos com o problema relatem  no bugs@netmake.com.br e feedback@netmake.com.br
Assim a netmake vê que a mais pessoas na mesma situação.
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada. Temos servidores dedicados.
Eu RTFM todo dia e você?

Jean Matos

  • Expert
  • *****
  • Mensagens: 993
    • Gestão de Construtoras
    • Email
Re:Imagem Não Aparece no Formulário
« Responder #8 Online: Abril 21, 2017, 10:35:43 am »
Povo..eu tenho formulario aqui com imagem de peças....e quando informo a dimensão que quero funciona perfeito....
V8.1, V9
Windows Server 2012 Enterpriser 64 bits
SqlServer 2012 datacenter 64 bits
Sistema Integrado de Gestão de Construtoras WaveTOR - Sistema Integrado de Gestão de Construtoras
Teófilo Otoni - MG
(33)8824-2775

Willian Formagio

  • Novato
  • *
  • Mensagens: 14
    • Email
Re:Imagem Não Aparece no Formulário
« Responder #9 Online: Abril 26, 2017, 05:09:36 pm »
Ao fazer o upload aparece normalmente, mas ao entrar no form novamente fica assim:


joeltonsilva

  • Expert
  • *****
  • Mensagens: 695
Re:Imagem Não Aparece no Formulário
« Responder #10 Online: Abril 27, 2017, 09:38:23 pm »
Povo..eu tenho formulario aqui com imagem de peças....e quando informo a dimensão que quero funciona perfeito....

Como fez?

Willian Formagio

  • Novato
  • *
  • Mensagens: 14
    • Email
Re:Imagem Não Aparece no Formulário
« Responder #11 Online: Maio 05, 2017, 03:01:00 pm »