Autor Tópico: ** RESOLVIDO ** Upload de imagens  (Lida 5612 vezes)

Agostinho

  • Avançado
  • ****
  • Mensagens: 277
    • Email
Re: ** RESOLVIDO ** Upload de imagens
« Responder #15 Online: Maio 23, 2011, 06:03:57 pm »
Acabei de efetuar a atualização, depois exclui o campo e criei de novo, agora ele mostra um gif do ajax, creio eu, e fica nisto, não sai do lugar..... Fiz a atualição automatica porque não sei fazer a manual, tem alguma diferença nisto?

ti.marcosdias

  • Novato
  • *
  • Mensagens: 2
Problemas com upload de imagens
« Responder #16 Online: Agosto 16, 2013, 01:17:50 pm »
Pessoal,

Estive observando em outros tópicos, mas não vi ninguém comentando o assunto, então vou aproveitar a thread de vocês.

Bom, tenho uma aplicação que faz upload de imagens, mas estou tendo problemas: assim que o usuário seleciona o arquivo, o campo de adição do arquivo exibe o nome da imagem apenas por alguns segundos e logo volta a exibir "Nenhum arquivo selecionado". Mesmo assim, é possível realizar o upload da imagem, porém, quando o upload termina, o link da imagem não é exibido até que eu saia e retorne à aplicação. Detalhe: estou utilizando a opção de exibir apenas o link da imagem.

Alguém já passou por isso?
« Última modificação: Agosto 16, 2013, 03:36:32 pm por ti.marcosdias »

Almeida

  • Expert
  • *****
  • Mensagens: 610
    • Email
Re:Problemas com upload de imagens
« Responder #17 Online: Agosto 16, 2013, 01:56:51 pm »
Pessoal,

Estive observando em outros tópicos, mas não ninguém comentando o assunto, então vou aproveitar a thread de vocês.

Bom, tenho uma aplicação que faz upload de imagens, mas estou tendo problemas: assim que o usuário seleciona o arquivo, o campo de adição do arquivo exibe o nome da imagem apenas por alguns segundos e logo volta a exibir "Nenhum arquivo selecionado". Mesmo assim, é possível realizar o upload da imagem, porém, quando o upload termina, o link da imagem não é exibido até que eu saia e retorne à aplicação. Detalhe: estou utilizando a opção de exibir apenas o link da imagem.

Alguém já passou por isso?

Não tenho uma solução para você, apenas um esclarecimento.

Ainda não usei muito esse modo de UPLOAD do SC, mas o mesmo confunde agente, porque?
Por que quando se seleciona a imagem o que todos tendem é trata-lá no onValidade, mas ao selecionar a IMG o SC já envia a mesma para o servidor,
então no onValidade vamos tratar a imagem já inserida no servidor.
Usando o atributo $this->Ini->path_doc, temos acesso a pasta que o scriptcase armazena a imagem, então concatenamos a pasta mais o nome da imagem e se tem o diretório completo da imagem, então só assim já podemos começar a tratar a imagem, move-la para uma pasta escolhida, mudar seu nome e talz.

Fui fazer um form de upload e percebi que o SC 7.1.003 está com bug nos Uploads,  não sei se foi corrigido na v 7.1.004.

Se eu estiver errado me corrijam.

Att.
Eliezer Almeida
eliezeralmeidago@hotmail.com
www.infotecsoft.com.br - Modernidade e Eficiência

ti.marcosdias

  • Novato
  • *
  • Mensagens: 2
Re:** RESOLVIDO ** Upload de imagens
« Responder #18 Online: Agosto 16, 2013, 03:44:33 pm »
Não tenho uma solução para você, apenas um esclarecimento.

Ainda não usei muito esse modo de UPLOAD do SC, mas o mesmo confunde agente, porque?
Por que quando se seleciona a imagem o que todos tendem é trata-lá no onValidade, mas ao selecionar a IMG o SC já envia a mesma para o servidor,
então no onValidade vamos tratar a imagem já inserida no servidor.
Usando o atributo $this->Ini->path_doc, temos acesso a pasta que o scriptcase armazena a imagem, então concatenamos a pasta mais o nome da imagem e se tem o diretório completo da imagem, então só assim já podemos começar a tratar a imagem, move-la para uma pasta escolhida, mudar seu nome e talz.

Fui fazer um form de upload e percebi que o SC 7.1.003 está com bug nos Uploads,  não sei se foi corrigido na v 7.1.004.

Se eu estiver errado me corrijam.

Almeida, sendo assim, a mensagem de "Nenhum arquivo selecionado" certamente se dá porque o arquivo já foi subido ao servidor. Correto?

Agora, o problema fica em retornar o link da imagem ao campo após a inserção. Sei como tratar o caminho e tal, mas não sei se vou conseguir criar um link igual ao que o SC cria por padrão, já que é um link com chamada JS que chama uma lightbox para exibir a imagem.

Almeida

  • Expert
  • *****
  • Mensagens: 610
    • Email
Re:** RESOLVIDO ** Upload de imagens
« Responder #19 Online: Agosto 16, 2013, 05:12:45 pm »
Não vou poder te ajudar sobre esse UPLOAD do SC, pois ainda não o fiz. Mas assim que eu fizer e nenhum dos nossos amigos tiver resolvido seu problema ou você mesmo. Publico oque consegui.

Att.
Eliezer Almeida
eliezeralmeidago@hotmail.com
www.infotecsoft.com.br - Modernidade e Eficiência