Autor Tópico: ** RESOLVIDO ** Problema depois da publicação - prod não conecta com mysql  (Lida 5176 vezes)

rrma

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 816
  • Quem com porcos se mistura tanto bate até que fura
    • Email
Amigos, preciso da ajuda de vcs, pois o suporte hoje não me atendeu.

Com o SC local, eu crio e uso normalmente uma conexão direta com meu banco mysql na web.
Depois que publico e hospedo o projeto, chamo o prod pra tentar criar a nova conexão.
Mesmo colocando todos os dados certos, o prod não consegue criar (fixar) a nova conexão.
Tentando editar a conexão já existente, mesmo mudando todos os dados, ele me retorna um erro, dizendo que não conseguiu conectar (erro 10060).
Mesmo tendo colocado um nome novo, pra conexão nova, ele me retorna o erro mostrando o nome da conexão antiga.

Tudo bem, parece ser permissão...
Setei 777 para a raiz do site inteiro, recursivamente, todos os arquivos e pastas, e o problema continua...
O servidor web é windows, no provedor hoteldaweb.

"Retirei os dados de conexão que havia colocado"

Essa é a minha primeira publicação, mas segui todos os passos do manual.
Esses dados são de um ambiente de testes, ainda não fiz nada de concreto, se puderem me ajudar ficarei grato.

Obrigado.
Rodrigo Araújo
« Última modificação: Dezembro 01, 2009, 08:55:25 am por Rodrigo Lins »
Rodrigo Araújo

Alcebiades

  • Novato
  • *
  • Mensagens: 28
    • Email
Re: Problema depois da publicação - prod não conecta com mysql
« Responder #1 Online: Novembro 30, 2009, 09:46:21 pm »
Boa noite

Seu servidor de banco esta funcionando perfeitamente... Mas o Ser servidor de Aplicação esta desatualizado... Vc Precisa atualizar o cliente MySql para ele poder conectar com o Banco e, bom seria mas não necessário, Atualizar o PHP.

Testei a conexão do meu servidor para o seu banco e funcionou muito bem, já o contrário informa que o cliente MySql esta desatualizado.

Espero ter Ajudado

rrma

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 816
  • Quem com porcos se mistura tanto bate até que fura
    • Email
Re: Problema depois da publicação - prod não conecta com mysql
« Responder #2 Online: Novembro 30, 2009, 10:07:00 pm »
Alcebíades,

Primeiramente obrigado pela ajuda.

Depois que fiz o post tive um estalo de setar permissões através do plesk do servidor, configurei tudo de novo pra 775, pra pasta de hospedagem toda.
Depois disso, na hora de criar uma conexão pelo prod, ao invés de usar o IP externo do servidor, eu coloquei "localhost".
Conectou...!
Agora to com outro pró.
O acesso ao site agora tá dando a msg: "Conexão com o banco de dados não localizada, contate o administrador do sistema. Conexão: HoteldaWeb_GCMWEB"
A questão é que "HoteldaWeb_GCMWEB" é o nome da conexão que eu tinha antes, dessa última vez que acessei o prod, eu apaguei todas as conexões e criei uma nova, com outro nome. Não era pra aparecer mais "HoteldaWeb_GCMWEB".
Acho que o prod não está conseguindo atualizar a aplicação com o nome da nova conexão, o que vc acha?

Obrigado mais uma vez...
Rodrigo Araújo
Rodrigo Araújo

Alcebiades

  • Novato
  • *
  • Mensagens: 28
    • Email
Re: Problema depois da publicação - prod não conecta com mysql
« Responder #3 Online: Novembro 30, 2009, 10:12:48 pm »
Veja

O nome da conexão deve ser aquele que vc colocou no projeto se for conecta01 o prod tem que ter uma conexão conecta01...

vc pode até criar outra conexões com outro nomes. mas elas não servirão para sua aplicação


rrma

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 816
  • Quem com porcos se mistura tanto bate até que fura
    • Email
Re: Problema depois da publicação - prod não conecta com mysql RESOLVIDO
« Responder #4 Online: Novembro 30, 2009, 10:36:47 pm »
HUMM, não me atentei pra esse detalhe, mas agora lembro de ter lido isso em algum lugar, vacilo de principiante...
Valeu!

Editando...
Obrigado Alcebíades!!! Era isso mesmo, agora que reparei na documentação online esse pequeno detalhe.

Rodrigo Araújo
« Última modificação: Novembro 30, 2009, 10:46:37 pm por rrma »
Rodrigo Araújo