Autor Tópico: Visualizando vídeos  (Lida 486 vezes)

jobsoncunha

  • Iniciante
  • **
  • Mensagens: 79
    • Email
Visualizando vídeos
« Online: Julho 18, 2016, 09:10:46 am »
Pessoal, bom dia,

Tenho um sistema numa emissora de TV que gerencia toda a programação. Em uma das rotinas o sistema armazena nas matérias editadas os respectivos vídeos que podem ser visualizados através de consulta com os seguintes comandos:

$v_arquivo = '../_lib/file/doc/materias_recebidas/' . {arquivo};

{vizualisar} = "
<html>
<video controls width='500' height='250'>
   <source src='" . $v_arquivo . "' type='video/mp4' preload; codecs='avc1.42E01E, mp4a.40.2'>
   <source src='" . $v_arquivo . "' type='video/webm' preload; codecs='vp8, vorbis'>
   <source src='" . $v_arquivo . "' type='video/ogg' preload; codecs='theora, vorbis'>
   <source src='" . $v_arquivo . "' type='video/mov' preload>
   <source src='" . $v_arquivo . "' type='video/jpg' preload>
  <param name='allowFullScreen' value='true'></param>
  <param name='allowscriptaccess' value='always'></param>
  <param name='ShowControls' value='true'>
  <param name='autostart' value='false'>
</video>
</html>
";

O problema é que, com a atualização da versão do SC-V8.1, o sistema deixou de mostrar o vídeo na consulta e mostra a seguinte mensagem: No video with supported format and MIME type found. Deixei em produção, por segurança, a versão anterior (SC-V8) onde o vídeo roda sem problemas.

Alguém tem idéia do porque o vídeo não roda na versão 8.1 do SC?

Jailton

  • Expert
  • *****
  • Mensagens: 2038
Re:Visualizando vídeos
« Responder #1 Online: Julho 18, 2016, 10:40:49 am »
Talvez você não se lembra.... mas quando fez este projeto no SC V8.

Você adicionou isto no apache, dá uma olhada no apache da V8 para comparar:
Apache HTTPD server - httpd.conf

An administrator (with root access ideally) should edit the global configuration file (/etc/httpd.d/httpd.conf for example) and add the new types at the end of the media type listing, the lass line that starts with AddType. The format is illustrated below.
AddType video/ogg .ogv
AddType video/mp4 .mp4
AddType video/webm .webm

Depois que mudar reiniciar...
« Última modificação: Julho 18, 2016, 11:39:04 am por Jailton »
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.

jobsoncunha

  • Iniciante
  • **
  • Mensagens: 79
    • Email
Re:Visualizando vídeos
« Responder #2 Online: Julho 19, 2016, 09:30:18 am »
Jailton

Não creio que seja este o problema, uma vez que o servidor é o mesmo. A diferença é que as versões do sistema estão em pastas distintas do mesmo servidor de aplicação, ou seja:

V8 na pasta ../sisgestaotv/

V81 na pasta ../sisgestaotv_81/


Jailton

  • Expert
  • *****
  • Mensagens: 2038
Re:Visualizando vídeos
« Responder #3 Online: Julho 19, 2016, 09:39:45 am »
Jailton

Não creio que seja este o problema, uma vez que o servidor é o mesmo. A diferença é que as versões do sistema estão em pastas distintas do mesmo servidor de aplicação, ou seja:

V8 na pasta ../sisgestaotv/

V81 na pasta ../sisgestaotv_81/



Usando o mesmo apache?, veja qual a porta que cada um esta usando.... no navegador:
Exemplo: http://localhost:8081/scriptcase/devel/iface/login.php
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.

Jailton

  • Expert
  • *****
  • Mensagens: 2038
Re:Visualizando vídeos
« Responder #4 Online: Julho 19, 2016, 10:31:21 am »
Fiz um teste aqui com seu código:
WINDOWS 10 PRO 64
Navegador Microsoft EDGE padrão.
Instalação do SC normal via .exe PHP 5.6 - SC 8.1.43

Nem mexi na config do apache, só fiz o teste e rodou normal em um formulário de controle com campo Label.




Se tiver usando na consulta agora experimente ativar o Javascript, antigamente não tinha esta opção.
« Última modificação: Julho 19, 2016, 10:46:43 am por Jailton »
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.