Autor Tópico: Problema Report PDF + HTML  (Lida 645 vezes)

lincoln19922

  • Novato
  • *
  • Mensagens: 4
    • Email
Problema Report PDF + HTML
« Online: Julho 07, 2016, 07:12:12 pm »
Pessoal estou com um Problema que deve ser extremamente besta, porém não consigo resolver.

Preciso gerar um Relatório PDF, com 2 campos que vem do meu Banco de dados,

1º - Código (Integer)
2º - Laudo (HTML - Blob)

Primeiramente tentei gerar via Report PDF, Coloquei a Query, e para testar no código coloquei o seguinte:

Código: [Selecionar]
           
sc_pdf_print($cell_estudo_id);
$teste = utf8_encode($cell_laudo);
$pdf->WriteHTML($teste, true, false, true, false, '');

Porém na impressão, o conteúdo da Variável $teste aparece em Branco.

Se eu deixo o Padrão do ScriptCase conforme Abaixo:

Código: [Selecionar]
           
sc_pdf_print($cell_estudo_id);
sc_pdf_print_html($cell_laudo);

Ele exibe o HTML na tela, porém não o interpreta, resultando nisso:

Código: [Selecionar]
<p>&nbsp;</p> <p>&nbsp;</p> <p><strong><span style="font-size: medium;">RX DE
CR&Acirc;NIO</span></strong></p> <p><strong><span style="font-size:
medium;">&nbsp;</span></strong></p> <p><strong><span style="font-size: medium;"><span style="font-size:
small;">Estruturas &oacute;sseas &iacute;ntegras.</span><br /></span></strong></p> <p><strong><span
style="font-size: medium;"><span style="font-size: small;">&nbsp;</span></span></strong></p>
<p><strong><span style="font-size: medium;"><span style="font-size: small;">Nota transpar&ecirc;ncia normal
dos seios paranasais.</span></span></strong></p>

Tentei mudar o Charset da aplicação para UTF-8 e ISO-8859-1, porém ainda sem sucesso.

Bom, como não estava dando certo com o Report PDF, pensei em fazer com o Blank (Seguindo sugestões do Forum e da internet), então rodei o seguinte código.

Código: [Selecionar]
sc_include_lib('TCPDF');

sc_lookup(ds_laudo, "select distinct(estudo_id), laudo from estudo_resultado where situacao_id = 3 and estudo_id
in (select id from estudo where origem_id = 127 and resultado_id is not null) limit 10 ");

$html = {ds_laudo[0][1]};


// create new PDF document
$pdf = new TCPDF(PDF_PAGE_ORIENTATION, PDF_UNIT, PDF_PAGE_FORMAT, false, 'UTF-8', false);

// set document information
$pdf->SetCreator(PDF_CREATOR);
$pdf->SetAuthor('Nicola Asuni');
$pdf->SetTitle('TCPDF Example 061');
$pdf->SetSubject('TCPDF Tutorial');
$pdf->SetKeywords('TCPDF, PDF, example, test, guide');

// set default header data
$pdf->SetHeaderData(PDF_HEADER_LOGO, PDF_HEADER_LOGO_WIDTH, PDF_HEADER_TITLE.' 061', PDF_HEADER_STRING);

// set header and footer fonts
$pdf->setHeaderFont(Array(PDF_FONT_NAME_MAIN, '', PDF_FONT_SIZE_MAIN));
$pdf->setFooterFont(Array(PDF_FONT_NAME_DATA, '', PDF_FONT_SIZE_DATA));

// set default monospaced font
$pdf->SetDefaultMonospacedFont(PDF_FONT_MONOSPACED);

// set margins
$pdf->SetMargins(PDF_MARGIN_LEFT, PDF_MARGIN_TOP, PDF_MARGIN_RIGHT);
$pdf->SetHeaderMargin(PDF_MARGIN_HEADER);
$pdf->SetFooterMargin(PDF_MARGIN_FOOTER);

// set auto page breaks
$pdf->SetAutoPageBreak(TRUE, PDF_MARGIN_BOTTOM);

// set image scale factor
$pdf->setImageScale(PDF_IMAGE_SCALE_RATIO);



// ---------------------------------------------------------

// set font
$pdf->SetFont('Helvetica', '', 10);

// add a page
$pdf->AddPage();

// output the HTML content
$pdf->writeHTML(utf8_encode($html), true, false, true, false, ''); 


//$pdf->SetFont('Times','B',16);
//$pdf->Cell(40,10,'Saida de texto!');
$pdf->Output();


Porém o retorno é o mesmo, sempre me retorna o HTML não interpretado.

Também tentei todas as combinações de Charset possíveis, e nada.

O mais engraçado é que se eu coloco o HTML na mão, ele interpreta certinho, porém quando vem do banco, ele não interpreta, apenas exibe como um texto.
 
Já não sei mais o que fazer, alguém me help?????
« Última modificação: Julho 08, 2016, 08:49:01 am por lincoln19922 »

Willian Fernando

  • Expert
  • *****
  • Mensagens: 1148
  • .....
    • Email
Re:[URGENTE] Problema Report PDF + HTML
« Responder #1 Online: Julho 07, 2016, 07:22:43 pm »
bom eu não sei nada de PDF, mas uma coisa eu sei, tu colocando URGENTE no titulo ou no Corpo do POST, e mais difícil que alguém te responda, pos aqui somo uma FÓRUM não o suporto da Netmake.

Por isso sugiro retirar o Urgente do Titulo desde POST e não utilizar-lo novamente si queres, respostas profissionais e com uma maior rapidez.

Eu mesmo vejo urgente e nem leio, justamente pelos pontos acima comentados, e tem varios outros membros que fazem o mesmo

lincoln19922

  • Novato
  • *
  • Mensagens: 4
    • Email
Re:[URGENTE] Problema Report PDF + HTML
« Responder #2 Online: Julho 08, 2016, 08:50:10 am »
bom eu não sei nada de PDF, mas uma coisa eu sei, tu colocando URGENTE no titulo ou no Corpo do POST, e mais difícil que alguém te responda, pos aqui somo uma FÓRUM não o suporto da Netmake.

Por isso sugiro retirar o Urgente do Titulo desde POST e não utilizar-lo novamente si queres, respostas profissionais e com uma maior rapidez.

Eu mesmo vejo urgente e nem leio, justamente pelos pontos acima comentados, e tem varios outros membros que fazem o mesmo

Urgente Removido Willian, Obrigado pelo Toque.