Autor Tópico: Formulário com Campo Lookup Demora para Salvar  (Lida 523 vezes)

R.O.N.A.L.D.O

  • Avançado
  • ****
  • Mensagens: 493
    • RC Sistemas Soluções Informáticas
    • Email
Formulário com Campo Lookup Demora para Salvar
« Online: Junho 21, 2016, 12:12:25 pm »
Eu estou enfrentando um problema com formulário onde se trabalha com campos do tipo Select com Lookup Automatico.

O problema é que o forumulário na hora de salvar demora muito para completar a operação.

O estranho é que no meu sistema eu tenho vários forms que usam o mesmo campo, e os forms mais antigos não apresentam o problema da demora, porém se eu re-compilar esse formulário ele passa a apresentar o problema da demora, portanto me parece que tem alguma diferença na geração de código que está causando isso.

Ressalto que isso só ocorre em lookups com tabelas relativamente grandes, mais de 3.000 registros, em lookups com tabelas pequenas não notei essa demora.

Mas volto a repetir, o mesmo lookup, na mesma tabela, em aplicações mais antigas do sistema não apresenta lentidão, mas basta recompilar para essa mesma aplicação ficar lenta.

Alguém mais percebeu isso, será mesmo um BUG do SC ???
Ronaldo Cocuroci
Analista de Sistemas
RC Sistemas Soluções Informáticas
www.rc-sistemas.com

R.O.N.A.L.D.O

  • Avançado
  • ****
  • Mensagens: 493
    • RC Sistemas Soluções Informáticas
    • Email
Re:Formulário com Campo Lookup Demora para Salvar
« Responder #1 Online: Junho 25, 2016, 09:21:35 am »
Já que não tive nenhum retorno por aqui enviei um email para a NM, espero que identifiquem e resolvam isso o quanto antes, pois esse problema está me trazendo muitos transtornos junto aos meus clientes.
Ronaldo Cocuroci
Analista de Sistemas
RC Sistemas Soluções Informáticas
www.rc-sistemas.com

R.O.N.A.L.D.O

  • Avançado
  • ****
  • Mensagens: 493
    • RC Sistemas Soluções Informáticas
    • Email
Re:Formulário com Campo Lookup Demora para Salvar
« Responder #2 Online: Julho 05, 2016, 08:36:03 am »
Atualizando o tópico, a NM enfim detectou o problema, é relacionado com o Google Chrome e provavelmente a macro sc_concat() nos lookups, aguardando atualização com a correção.
Ronaldo Cocuroci
Analista de Sistemas
RC Sistemas Soluções Informáticas
www.rc-sistemas.com