Oferta Limitada! 40% OFF para compra e renovaÇÃo. Comprar agora

Autor Tópico: Qual versão do PHP é compatível com as aplicações geradas pelo Scriptcase?  (Lida 1866 vezes)

Spybr

  • Intermediário
  • ***
  • Mensagens: 115
Gostaria de saber qual versão do PHP é necessária para rodar as aplicações geradas por um projeto desenvolvido no Scriptcase? Alguem saberia me dizer se é compatível com PHP 5.2.2 ?
« Última modificação: Maio 13, 2016, 09:16:10 am por Ronyan Alves »

robertobru

  • Avançado
  • ****
  • Mensagens: 494
    • Email
Re:Qual versão do PHP é compatível com as aplicações geradas pelo Scriptcase?
« Responder #1 Online: Maio 12, 2016, 09:55:26 pm »
Somente pra se ter uma ideia, hoje minhas aplicações rodam no php na versão 5.6.8
Dependendo da versão do SC, acho no mínimo o php 5.4 será necessário.

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 2166
  • Focalize as oportunidades e não os obstáculos.
    • Simão & Bühler Ltda
    • Email
Re:Qual versão do PHP é compatível com as aplicações geradas pelo Scriptcase?
« Responder #2 Online: Maio 12, 2016, 11:15:10 pm »
O ideal é:
scriptcase 5 -> php 5.2
scritpcase 6 -> php 5.3
scriptase <= 7.0.013 -> php 5.3
scriptcase >= 7.0.014 -> php 5.4
scriptcase 8.0.xxx -> php 5.4
scriptcase 8.1.xxx -> php 5.4 ou php 5.6

PS: scriptcase 8.1.xxx eu sempre uso com  php 5.6
« Última modificação: Maio 12, 2016, 11:21:13 pm por Alexandre Pereira Bühler »
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada. Temos servidores dedicados.
Linux User: 397546 -> https://www.linuxcounter.net
Grupo Telegram -> https://t.me/scriptcasebr

Jailton

  • Expert
  • *****
  • Mensagens: 2642
Re:Qual versão do PHP é compatível com as aplicações geradas pelo Scriptcase?
« Responder #3 Online: Maio 13, 2016, 07:44:21 am »
O ideal é:
scriptcase 5 -> php 5.2
scritpcase 6 -> php 5.3
scriptase <= 7.0.013 -> php 5.3
scriptcase >= 7.0.014 -> php 5.4
scriptcase 8.0.xxx -> php 5.4
scriptcase 8.1.xxx -> php 5.4 ou php 5.6

PS: scriptcase 8.1.xxx eu sempre uso com  php 5.6



Será que na V9 teremos o PHP 7.0 que é 3x mais rápido do que a 5.6:
« Última modificação: Maio 13, 2016, 07:46:11 am por Jailton »
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 2166
  • Focalize as oportunidades e não os obstáculos.
    • Simão & Bühler Ltda
    • Email
Re:Qual versão do PHP é compatível com as aplicações geradas pelo Scriptcase?
« Responder #4 Online: Maio 13, 2016, 09:48:00 am »
O scriptcase segue junto com o Zend Guard e por enquanto ele esta assim:
http://www.zend.com/en/products/zend-guard#whatsnew

Changes in Zend Guard from version 6.0 to 7.0
Full support for PHP 5.5 and 5.6

Changes in Zend Guard from version 5.5 to 6.0
Full support for PHP 5.4

Changes in Zend Guard from version 5.0.1 to 5.5
Full support for PHP 5.3

Logo, não vejo como sair o scriptcase 9 com o php 7.0
Somente se o Zend Guard 8.0 com suporte  a php 7.0 vier antes do lançamento do scriptcase 9.
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada. Temos servidores dedicados.
Linux User: 397546 -> https://www.linuxcounter.net
Grupo Telegram -> https://t.me/scriptcasebr