Autor Tópico: Problema Publicação - MySql não encontra base  (Lida 838 vezes)

mvinicius

  • Novato
  • *
  • Mensagens: 29
  • Não há recompensa sem esforço.
    • Email
Problema Publicação - MySql não encontra base
« Online: Março 08, 2016, 01:15:36 pm »
Srs,




Algo estranho esta acontecendo. Desenvolvi uma aplicação com MySql e Oracle (Via Odbc). A base não é local, esta num servidor externo, em outro pais. No ambiente de desenvolvimento, tudo funciona corretamente. Fui publicar a aplicação (no mesmo servidor) pra disponibilizar para validação, o mysql conecta com o servidor, mas não lista base de dados para seleção, deixando o sistema inoperante.
Converti o sistema para v8, e aconteceu o inverso. o MySql funciona e o ODBC não.
Alguem ja passou por isso ???




sds




MV
M. Vinicius
Consultor de Sistemas Corporativos

Jailton

  • Expert
  • *****
  • Mensagens: 2041
Re:Problema Publicação - MySql não encontra base
« Responder #1 Online: Março 08, 2016, 02:50:07 pm »
Quando se usa ODBC você deve liberar a faixa de IP, que esta usando na rede que esta o ODBC lá no servidor do Mysql e Oracle na parte 'acesso remoto'.

Exemplo: o IP do servidor ODBC é 200.298.394.1, ai libera lá: 200.% ou o próprio IP inteiro se for IP fixo.
O Princípio da Vibração. "Nada está parado, tudo se move, tudo vibra". Caibalion.

mvinicius

  • Novato
  • *
  • Mensagens: 29
  • Não há recompensa sem esforço.
    • Email
Re:Problema Publicação - MySql não encontra base
« Responder #2 Online: Março 09, 2016, 10:41:39 am »
Jailton,


Está liberado. No ambiente de desenvolvimento funciona 100%, testo todas as aplicações, e tudo rola 100%. O problema é que quando eu publico a aplicação (para teste uso o mesmo servidor de desenvolvimento para os usuários chaves validarem as telas, depois de concluído que migro para o servidor de produção), partindo desse preceito, não devia ter que liberar IP dum servidor que já está liberado, além do mais, minha rede rola com um IP externo Único que já esta liberado no servidor onde hospedo o banco, logo não teria que liberar de novo.
Por via das duvidas, testei em outro servidor web que tenho na rede, com PHP mais novo (utilizo SC7 e SC8, o referido erro só ocorre nas aplicações geradas no SC7, publicando as mesmas no servidor onde esta o SC7 ou no server do SC8)
E, uso a conexão ODBC para um server local. Com o SC7 funciona, com o SC8 não.


sds
M. Vinicius
Consultor de Sistemas Corporativos