Autor Tópico: Inserindo Novos Campos no Formulario  (Lida 2208 vezes)

zegitz

  • Novato
  • *
  • Mensagens: 10
Inserindo Novos Campos no Formulario
« Online: Setembro 03, 2009, 03:29:01 pm »
Olá pessoal!

Estou tentando inserir novos campos no formulário mas não estou conseguindo.
1 - Criei os campos direto no postgres.
2 - Fui em Aplicação>Sincronizar Tabela>
3 - Ele atualizou e "adicionou" os campos.
4 - Fui em Selecionar Campos e adicionei e organizei os mesmos no Formulário.
5 - Configurei os Campos normalmente e gerei a aplicação.

Esses foram os passos que fiz , mas quando executo o Formulário os campos não aparecem.

Agradeço se me ajudarem.

Att.
José Gitz

Rodrigo Lins

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 504
    • Overalt I.T
Re: Inserindo Novos Campos no Formulario
« Responder #1 Online: Setembro 03, 2009, 04:57:08 pm »
Boa Tarde,

Eu fiz os mesmos passos que você informou e no meu formulário funcionou corretamente....

Este seu form tem blocos? Será que ele não está em um bloco escondido? Está marcado como campo escondido? Ou algum detalhe que esqueceu?

O teste que fiz foi, criar um formulário com uma tabela de teste com 2 campos, gerei a aplicação executei e depois no banco de dados criei mais 1 campo, depois fui em sincronizar no scriptcase, coloquei o campo para dentro do formulário e executei... e funcionou.

Rodrigo Lins.

zegitz

  • Novato
  • *
  • Mensagens: 10
Re: Inserindo Novos Campos no Formulario
« Responder #2 Online: Setembro 04, 2009, 01:32:19 am »
Pois eu também pensei nisso , mas olhei todos os detalhes no blocos e nos campos. Cheguei a excluir todos os blocos deixar tudo em 1 só pra pelo menos poder ver os campos que adicionei , mas nada.Também  deixei um dos novos campos como Pkey , mas o scriptcase simplesmente ignora as minhas alterações nesses campos.

A única solução que eu encontrei até agora foi fazer tudo do início.

agradeço a ajuda.

Att.
José Gitz

waae

  • Avançado
  • ****
  • Mensagens: 292
    • Email
Re: Inserindo Novos Campos no Formulario
« Responder #3 Online: Setembro 22, 2009, 09:46:48 am »
com novos campos tb nunca tive problema depois de "sincronizar a tabela", mas quando mudo algum campo manualmente no banco... como por exemplo um campo que era varchar 100 passar a ser text... msm que ele mostre que irá atualizá-lo.... ele nao muda o tipo do campo... ai eu tenho que excluir o campo no banco.... sincronizar a tabela no SC ... incluir o campo com o msm nome e de tipo diferente.... e sincronizar a tabela de novo.... Isso qdo não sei pq.... crio um campo tipo numerico ou varchar... e ao criar o formulário... ele teima em colocar o campo como tipo data!!
=\