Autor Tópico: Atualização para a versão 8.1.008  (Lida 646 vezes)

reginaldorjl

  • Novato
  • *
  • Mensagens: 8
    • Email
Atualização para a versão 8.1.008
« Online: Setembro 14, 2015, 11:15:57 am »
Olá pessoal,

Bom dia!

Alguém está tendo problemas na geração e execução de aplicações geradas com a nova versãi 8.1.008? O meu, desde que atualizei tem dado tal mensagem de erro. A aplicação é mais simples possível. Sem nenhuma configuração extra. Apenas conexão e 1 campo de exibição. O mesmo erro dá com aplicação grid ou form.

Fatal error: Call to undefined function sc_convert_encoding() in /opt/NetMake/v81/wwwroot/scriptcase/devel/generator/nm_gp_img_cab.php on line 26

Quando tento executar a grid dá o seguinte:

2 = include_once(/opt/NetMake/v81/wwwroot/scriptcase/prod/lib/php/nm_utf8.php): failed to open stream: Permission denied
/opt/NetMake/v81/wwwroot/scriptcase/devel/compat/compat.inc.php 419


Quando tento executar o form dá o seguinte:

include_once(): Failed opening '../../prod/lib/php/nm_utf8.php' for inclusion (include_path='.:/extra/build/php/lib/php') | Script: /opt/NetMake/v81/wwwroot/scriptcase/devel/class/generator/gerador.php linha: 14

Alguém sabe o que é, e como resolver.

Essa versão 8.1 está difícil de estabilizar... o:)

Desde já agradeço,

Reginaldo Lima (Recife/PE)

saulobborges

  • Expert
  • *****
  • Mensagens: 1392
    • SGi Sistemas
    • Email
Re:Atualização para a versão 8.1.008
« Responder #1 Online: Setembro 14, 2015, 11:17:55 am »
Gere novamente suas aplicações.

reginaldorjl

  • Novato
  • *
  • Mensagens: 8
    • Email
Re:Atualização para a versão 8.1.008
« Responder #2 Online: Setembro 14, 2015, 11:23:07 am »
Saulo,

O problema é que não consigo gerar a aplicação. Como disse anteriormente, é uma aplicação nova, dentro de um projeto zerado, apenas como teste. O SC não consegue nem gerar, muito menos executar. Nem grid, nem form.

Kleyber

  • Expert
  • *****
  • Mensagens: 2232
    • Email
Re:Atualização para a versão 8.1.008
« Responder #3 Online: Setembro 14, 2015, 11:30:30 am »
Mande atualizar novamente pois podem existir arquivos a serem baixados. Se não der certo, faça uma atualização manual do SC.
Kleyber Derick

ITIL® V3 Foundation Certified
Analista de Sistemas
São Luís - Maranhão
www.tkinformidia.net

Willian Fernando

  • Expert
  • *****
  • Mensagens: 1148
  • .....
    • Email
Re:Atualização para a versão 8.1.008
« Responder #4 Online: Setembro 14, 2015, 11:34:44 am »
esta parecendo falta de privilegios na pasta

é linux??

FredKeyster

  • Expert
  • *****
  • Mensagens: 1702
  • DEWENNINMEN
    • Email
Re:Atualização para a versão 8.1.008
« Responder #5 Online: Setembro 14, 2015, 11:37:57 am »
Pessoal, vcs publicaram alguma coisa depois dessa release? Pois a segurança do SC não esta funcionando muito bem em produção. Mesmo o usuário com permissão de acesso ele esta bloqueando. Alguém percebeu isso ?
F. A.
Analista de Sistemas

reginaldorjl

  • Novato
  • *
  • Mensagens: 8
    • Email
Re:Atualização para a versão 8.1.008
« Responder #6 Online: Setembro 14, 2015, 01:30:38 pm »
Kleyber,

Kleyber, a atualização já foi manual. Houve a instalação normal pelo .run da versão 8.1.004 e depois atualizei manualmente para a ver 8.1.008. Até ai tudo bem, porém dá erro quando mando gerar ou executar.

Willian, o ambiente é linux sim. Debian. Não mexi nas permissões. Qual pasta você acha que deve alterar?

Obrigado pela atenção pessoal!

reginaldorjl

  • Novato
  • *
  • Mensagens: 8
    • Email
Re:Atualização para a versão 8.1.008
« Responder #7 Online: Setembro 15, 2015, 10:33:26 am »
Obrigado pessoal.

Realmente era o charset. Deu outro erro, mas era permissão. Tive que dar permissão de escrita na pasta prod e devel. Consegui gerar!

Muito obrigado  pela atenção de todos!

Estarei acompanhando o fórum para ver se consigo ajudar alguém.

Abç