Autor Tópico: Incompatibilidade de bibliotecas no Ambiente de Produção  (Lida 2430 vezes)

jamberly

  • Novato
  • *
  • Mensagens: 13
    • Cijam TeleInformatica
Incompatibilidade de bibliotecas no Ambiente de Produção
« Online: Abril 25, 2009, 08:53:10 pm »
Boa Noite, é com tristeza que informo que meu HD queimou ....
OK Bola para frente tudo reinstalado, windows, xampp, scriptcase, amb. de produção.
Backup recuperado, e fui gerar minhas aplicações de novo até aí tudo bem, mas quando tento rodar no apache recebo a seguinte mensagem :
__________________________________________________________________________________________

A aplicação não pode ser executada, pois não é compatível com as bibliotecas comuns. Favor entrar em contato com o administrador do servidor.
__________________________________________________________________________________________

Desde já obrigado
Jamberly

Rodrigo Lins

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 504
    • Overalt I.T
Re: Incompatibilidade de bibliotecas no Ambiente de Produção
« Responder #1 Online: Abril 26, 2009, 12:14:29 pm »
O que pode estar ocorrendo de fato, é estar com versões diferentes.

Na release 4.015 do scriptcase houveram mudanças significativas, e que o ambiente de produção precisou ser atualizado.

Para verificar as versões do scriptcase e ambiente de produção observe o seguinte:

- Acesse o ScriptCase e vá no menu "Ajuda --> Sobre".
- Agora acesse o diretório onde está o ambiente de produção a pasta '/prod/lib/php/' o arquivo 'ver.dat' (abra ele no bloco de notas mesmo) e verifique a versão.

Se o ambiente de produção estiver desatualizado em relação ao seu scriptcase, será necessário atualizar.

Espero ter ajudado.

Rodrigo Lins.

jamberly

  • Novato
  • *
  • Mensagens: 13
    • Cijam TeleInformatica
Re: Incompatibilidade de bibliotecas no Ambiente de Produção
« Responder #2 Online: Abril 26, 2009, 12:54:55 pm »
Verifiquei as versões são iguais o problema persiste.

Obrigado

Rodrigo Lins

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 504
    • Overalt I.T
Re: Incompatibilidade de bibliotecas no Ambiente de Produção
« Responder #3 Online: Abril 27, 2009, 04:33:45 pm »
Seria interessante você entrar em contato com o suporte, para eles testarem e verificar qual seria o problema.

ou enviar um email para bugs@netmake.com.br

Rodrigo Lins.

jamberly

  • Novato
  • *
  • Mensagens: 13
    • Cijam TeleInformatica
Re: Incompatibilidade de bibliotecas no Ambiente de Produção
« Responder #4 Online: Abril 28, 2009, 09:12:36 pm »
Obrigado pela Dica, mas recebi da netmake a seguinte resposta:

Gere as aplicaões pela forma expressa já com as bibliotecas que vai funcionar.

Eu publicava na forma avançada e não sei por que parou,

Ps.: Pena que agora o ambiente de produção funciona, mas não acha meus bancos de dados, como diriam meus filhos "aff". vou abrir outro tópico obrigado a todos.

Rodrigo Lins

  • Global Moderator
  • Expert
  • *****
  • Mensagens: 504
    • Overalt I.T
Re: Incompatibilidade de bibliotecas no Ambiente de Produção
« Responder #5 Online: Abril 29, 2009, 02:10:22 pm »

Hum... Estranho.. é para funcionar com a publicação avançada. Mas, tudo bem, no caso você precisa criar a conexão no ambiente de produção que é levado neste tipo de publicação (expressa).

Exemplo:

http://localhost/nomesistema/_lib/prod/

Acesse este link para criar a conexão, lembrando que o que vai ser igual é o final do link  /_lib/prod/  o resto do caminho irá depender da sua configuração.

Lembrando também que o nome da conexão precisa ser o mesmo nome que as aplicações utilizam.

Rodrigo Lins.