Autor Tópico: Consultas não funcionam após migração  (Lida 2288 vezes)

Codasp

  • Novato
  • *
  • Mensagens: 9
    • Email
Consultas não funcionam após migração
« Online: Abril 16, 2009, 11:41:54 am »
Migrei meu servidor do Scriptcase (Versão 2) para um servidor Linux. Teoricamente tudo foi feito corretamente:
- Chave de Licença atualizada;
- Backup das aplicações em ordem;
- Bancos de dados funcionando perfeitamente.

Apesar disso, as aplicações de consulta não rodam. Todas dão a seguinte mensagem (mudando, é claro, o nome da aplicação):

Fatal error: Class 'Oper_Obras_relatorio_lookup' not found in /var/www/scriptcase/app/Operacional/Oper_Obras_relatorio/Oper_Obras_relatorio.php on line 682

As linhas próximas de onde estaria o problema é a seguinte:

ln 682>      $this->lookup       = new Oper_Obras_relatorio_lookup();
ln 683>      $this->lookup->db   = $this->db;
ln 684>      $this->lookup->ini  = $this->ini;
ln 685>      $this->lookup->erro = $this->erro;

 

O erro está ocorrendo em todas as minhas aplicações de consuta. Os formulários estão funcionando perfeitamente.

weber

  • Expert
  • *****
  • Mensagens: 516
    • Email
Re: Consultas não funcionam após migração
« Responder #1 Online: Setembro 24, 2009, 12:40:31 am »
Por acaso, vc veriifcou se as tuas consultas usam como base SQL uma view, pq se for o caso, em muitos servidores existe um probleminha de config exemplo:

na maquina local vc faz algo do tipo select id, nome from cadastro e quando passa pro server remoto teria q montar algo do tipo
select cadastro.id, cadastro.nome from cadastro....