Autor Tópico: [RESOLVIDO] Multi-upload não insere foto antes de inserir em campo normal M/D  (Lida 1191 vezes)

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
Boa noite senhores!

Desde de já agradeço a ajuda de todos.

Procurei respostas antes de postar este!

Tenho Uma Tabela Pai de nome, Ocorrido [Id_Ocorrido/Descricao/data] e Fotos_Ocorrido [id_fotos/Id_Ocorrido/Foto], então simplificando: No Scriptcase fiz um campo dinâmico tipo IMAGEM BANCO DE DADOS pois preciso disso no banco (Não façam polêmicas sobre isso, O cliente quis assim!), o problema é que este campo dinâmico não insere fotos sem antes inserir uma foto com campo físico Foto, e este campo Foto não será visível ao usuário, ele é só para inserir as fotos do campo dinâmico criado na aplicação, quando dou debug mostra o campo id_fotos = 0, acho que por isso não consigo inserir as fotos usando  Multi-upload. Mas quando habilito o campo Foto consigo inserir uma foto, aí o campo criado na aplicação passa a funcionar aceitando inserir  Multi-upload de fotos. Observação isso acontece usando mestre/detalhe não  testei uma aplicação sozinha de fotos sem relacionamento. estou usando versão 8 atualizada.

Aguardo retorno por favor.
« Última modificação: Fevereiro 23, 2015, 09:06:19 am por Yuri Esteves »
Deus é fiel!

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 1642
  • Nunca estabeleça um teto para os seus rendimentos.
    • Simão & Bühler Ltda
    • Email
Re:Campo Dinamico Multi-upload Não insere foto antes de inserir em compo normal
« Responder #1 Online: Fevereiro 07, 2015, 10:47:20 pm »
Boa noite,
Posta seu código e o ddl da tabela para podermos simular.
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada Scriptcase desenvolvimento e produção. Temos servidores dedicados Scriptcase.
Eu RTFM todo dia e você?

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
Re:Campo Dinamico Multi-upload Não insere foto antes de inserir em compo normal
« Responder #2 Online: Fevereiro 07, 2015, 11:31:17 pm »
Configuração ScriptCase.
« Última modificação: Fevereiro 08, 2015, 08:41:14 am por Robson »
Deus é fiel!

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
Re:Campo Dinamico Multi-upload Não insere foto antes de inserir em compo normal
« Responder #3 Online: Fevereiro 09, 2015, 06:10:05 pm »
Boa noite!


Alexandre Pereira Bühler, conseguiu simular algo, para solucionar esta dúvida?

O problema ainda continua, e pior, quando habilito o campo e tento inserir com multi upload ele insere as fotos, porem insere também uma imagem sem conteúdo, acho que só para inserir o auto incremento, achei estranho, alguém se habilita a ajudar?

Obrigado.
Deus é fiel!

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 1642
  • Nunca estabeleça um teto para os seus rendimentos.
    • Simão & Bühler Ltda
    • Email
Re:Campo Dinamico Multi-upload Não insere foto antes de inserir em compo normal
« Responder #4 Online: Fevereiro 09, 2015, 06:20:10 pm »
Robson,
Ainda não consegui, este final de semana e hoje foi somente para suporte remoto.
Amanhã creio ter um folga e testo.
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada Scriptcase desenvolvimento e produção. Temos servidores dedicados Scriptcase.
Eu RTFM todo dia e você?

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
Re:Campo Dinamico Multi-upload Não insere foto antes de inserir em compo normal
« Responder #5 Online: Fevereiro 09, 2015, 08:45:29 pm »
Certo, aguardo...

Enquanto isso vou tentando, mas só amanhã também! Boa Noite.
« Última modificação: Fevereiro 09, 2015, 08:48:34 pm por Robson »
Deus é fiel!

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 1642
  • Nunca estabeleça um teto para os seus rendimentos.
    • Simão & Bühler Ltda
    • Email
Re:Campo Dinamico Multi-upload Não insere foto antes de inserir em compo normal
« Responder #6 Online: Fevereiro 10, 2015, 06:40:54 pm »
Boa noite,
Ou eu to cansado ou este negócio que você quer fazer tá difícil mesmo.
Mas vamos tentando...
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada Scriptcase desenvolvimento e produção. Temos servidores dedicados Scriptcase.
Eu RTFM todo dia e você?

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 1642
  • Nunca estabeleça um teto para os seus rendimentos.
    • Simão & Bühler Ltda
    • Email
Re:Campo Dinamico Multi-upload Não insere foto antes de inserir em compo normal
« Responder #7 Online: Fevereiro 10, 2015, 06:50:10 pm »
Pensei em utilizar uma view atualizável, mas não sei se dará certo.
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada Scriptcase desenvolvimento e produção. Temos servidores dedicados Scriptcase.
Eu RTFM todo dia e você?

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
Re:Campo Dinamico Multi-upload Não insere foto antes de inserir em compo normal
« Responder #8 Online: Fevereiro 10, 2015, 08:14:15 pm »
Boa Noite, Alexandre Pereira Bühler.

Agradeço sua cooperação, pena que ninguém da NetMake se pronunciou (Hoje dia 19/02/2015, Procurei ajuda e eles responderam), isso não devia acontecer pelos menos é o que esperava-se, mas deve ser algum bug interno que vão além de minha compreensão (Foi bug de usuário), pois sei php mas os códigos internos da NetMake, aí meu amigo para mim é um mistério (Ainda é um mistério), posso algum dia até investigar os códigos misteriosos que lá existe mas no momento estou preocupado em resolver isso (Hoje dia 19/02/2015 Resolvido), vou tentando por aqui, e se você achar a solução não deixe de ser gentil em avisar e agradeço muito sua ajuda, obrigado Alexandre Pereira Bühler.

Observação: Algo que devia ser simples pela promessa da ferramenta, esbarra-se na não reposta de quem deveria ao menos se pronunciar! (Após procurar os meios certos fui atendido)

Boa noite a todos.
« Última modificação: Fevereiro 19, 2015, 06:17:21 pm por Robson »
Deus é fiel!

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
Multi-upload não insere foto antes de inserir em compo normal.
« Responder #9 Online: Fevereiro 12, 2015, 12:13:16 pm »
Boa tarde!

Ainda não entendo, este multi upload com mestre/detalhe, quando adiciono as fotos ele simplesmente não mostra o botão atualizar no detalhe, e se eu colocar incluir ele some com as fotos, depois vou em cancelar aparece as fotos com uma foto inserida sem imagem, não sei mais o que fazer, alguém da Netmake poderia simular isso (Hoje dia 19/02/2015 Fui orientado pelo suporte), e me ajudar por favor.

« Última modificação: Fevereiro 19, 2015, 06:20:24 pm por Robson »
Deus é fiel!

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
Multi-upload não insere foto antes de inserir em compo normal.
« Responder #10 Online: Fevereiro 12, 2015, 12:17:37 pm »
Vejam.
« Última modificação: Fevereiro 16, 2015, 10:39:28 am por Robson »
Deus é fiel!

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
Re:[Alguém Ajuda?]Multi-upload não insere foto antes de inserir em campo normal M/D
« Responder #11 Online: Fevereiro 17, 2015, 07:19:50 am »
Este tópico passou pelo mesmo problema, e ninguém respondeu, será que é impossível obter uma resposta, pelo menos para dizer: Não conseguimos consertar este bug. (Não tinha bug foi erro de lógica)

https://www.scriptcase.com.br/forum/index.php/topic,8769.0.html

Robson
« Última modificação: Fevereiro 19, 2015, 06:21:55 pm por Robson »
Deus é fiel!

Alexandre Pereira Bühler

  • Expert
  • *****
  • Mensagens: 1642
  • Nunca estabeleça um teto para os seus rendimentos.
    • Simão & Bühler Ltda
    • Email
Re:[Alguém Ajuda?]Multi-upload não insere foto antes de inserir em campo normal M/D
« Responder #12 Online: Fevereiro 17, 2015, 08:05:09 am »
Robson,
Minhas tentativas foram falhas.
Aqui no Fórum não vai conseguir muita coisa se for bug mesmo.
Relate o ocorrido nos e-mails:
bugs@netmake.com.br e
feedback@netmake.com.br
--
Alexandre Pereira Bühler
https://www.simaoebuhler.com.br
Hospedagem compartilhada Scriptcase desenvolvimento e produção. Temos servidores dedicados Scriptcase.
Eu RTFM todo dia e você?

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
Re:[Alguém Ajuda?]Multi-upload não insere foto antes de inserir em campo normal M/D
« Responder #13 Online: Fevereiro 17, 2015, 08:32:10 am »
Alexandre Pereira Bühler, bom dia!

Mais uma vez muito obrigado, vou fazer o que você sugeriu. Vou também tentar fazer no braço, e assim que consegui vou postar aqui.

Robson.
Deus é fiel!

Robson

  • Novato
  • *
  • Mensagens: 23
  • Esse cara sou eu!
[RESOLVIDO] Multi-upload não insere foto antes de inserir em campo normal M/D
« Responder #14 Online: Fevereiro 19, 2015, 05:56:31 pm »
Boa noite senhores!

Tópico resolvido!

Após alguns dias tentando resolver este problema e seguindo a sugestão do Alexandre Pereira Bühler, entrei em contato com o suporte e fui atendido com muita paciência pelo senhor:
Yuri Esteves <yuri@netmake.com.br>, e após explicar minha situação ele chegou a seguinte conclusão:

Foi erro de lógica ao usar o recurso do campo multi upload.

Eu estava usando o campo na mesma tabela no caso "Fotos" e o correto é usar o campo multi upload na tabela mestre "Ocorrência" e referenciar na tabela filha no caso "Fotos", após fazer este ajuste com a ajuda do senhor Yuri Esteves <yuri@netmake.com.br>, a aplicação com este recurso funcionou como esperado.
Agradeço a todos que se propuseram a ajudar, muito obrigado.

Robson
Deus é fiel!