Abrir tópico com a navegação

Conectando com PostgreSQL

A instalação automática do Scriptcase já habilita automáticamente a conexão PostgreSQL.

Para realizar a conexão com o banco PostgreSQL, siga os passos abaixo.

Abrir tópico com a navegação

Drivers PostgreSQL

Atualmente o ScriptCase possui quatro drivers para conexão com o banco de dados PostgreSQL: PostgreSQL PDO, PostgreSQL 7 ou Acima, PostgreSQL 6.4 ou acima e PostgreSQL 6.3 ou abaixo.

Abaixo, podemos ver suas características:

PostgreSQL PDO ( Recomendado ) : Possibilita a conexão ao banco de dados PostgreSQL utilizando o driver nativo do PHP. Superior em velocidade de processamento e em constante atualização.

PostgreSQL 7 ou Acima : Possibilita realizar conexão e utilizar as novas funcionalidades do banco de dados PostgreSQL 7 ou superior.

PostgreSQL 6.4 ou acima : Possibilita realizar conexão e utilizar as funcionalidades do banco de dados PostgreSQL 6.4 e 6.5.

PostgreSQL 6.3 ou abaixo : Possibilita realizar conexão e utilizar as funcionalidades do banco de dados PostgreSQL 6.3 ou inferior.

Criando um Conexão no Scriptcase

Conectando-se ao PostgreSQL no Scriptcase

Abrir tópico com a navegação

Agora acessaremos o ScriptCase pelo browser e vamos criar a conexão com a base de dados do PostgreSQL.

Passo 1: Acesse o seu ScriptCase, por exemplo, http://localhost:8081/scriptcase/ na barra de ferramentes vá até o ícone destacado na figura a abaixo, referente a "Nova Conexão".

Passo 2: Após clicar em “Nova”, irá aparecer a tela de criação de conexão, clique na imagem do banco PostgreSQL.

Passo 3: Na imagem a seguir, preencha as especificações pedidas:

Para mais detalhes na configuração da conexão do banco da dados clique na aba Avançado

Filtro - Clicando nessa Aba, aparecerá a seguinte tela:

Passo 4: Sempre teste a sua conexão antes de concluir a mesma, se aparecer a mensagem “Conexão Realizada com Sucesso", então conclua a criação da conexão.
Se houver alguma falha na conexão, reveja os campos preenchidos, principalmente o usuário, senha, servidor e a base de dados.

Verifique se o módulo está devidamente habilitado no PHP.